MATLAB and Simulink Requirements

Product Requirements & Platform Availability for Vehicle Network Toolbox

Supported Platforms

Windows, Linux

Product Requirements

  • Requires MATLAB
  • On Linux® platform, support is limited to reading MDF files, encoding and decoding CAN and CAN FD messages using MathWorks virtual channels, and sending and receiving J1939 parameter groups. Hardware support on Linux is available for PEAK-System CAN interface hardware and Kvaser CAN interface hardware only.

Eligible for Use with MATLAB Compiler and Simulink Compiler

Yes - see details

Eligible for Use with Parallel Computing Toolbox and MATLAB Parallel Server

Yes

Introduced in R2009a

View requirements for another product: