Product Requirements & Platform Availability for MATLAB Web App Server

Supported Platforms

Mac, Windows, Linux

Product Requirements

Does not require MATLAB or Simulink

Eligible for Use with MATLAB Compiler and Simulink Compiler

Yes

Eligible for Use with Parallel Computing Toolbox and MATLAB Parallel Server

Yes

System Requirements

Hardware Requirements

MATLAB® Web App Server can be installed on all hardware platforms and operating systems that MATLAB supports. The hardware requirements are:

  • Minimum 60 GB of disk capacity to accommodate the server software installation and log files.
  • Minimum 1GB RAM per worker.
  • Allocation of 1 processor core (or virtual core) per 4 workers; 2 cores minimum.

Software Requirements

An installation of MATLAB Runtime is required. MATLAB Runtime starting from R2019b up until the most recent release is supported. You can use multiple versions of the runtime with the server.

The version of MATLAB Runtime must match the version of MATLAB you used to package the web app archive (.ctf file). For additional information, please see Support for MATLAB Updates in MATLAB Runtime FAQ.

MATLAB Compiler™ is required to package MATLAB apps as web app archives (.ctf files) to run on MATLAB Web App Server.

Only MATLAB apps created using App Designer can be hosted and shared using MATLAB Web App Server.

Network Requirements

Network connectivity between the client and MATLAB Web App Server must be available via an open port, which is the listening port on the server. The port on which the server listens can be modified using the webapps-config script which is available in MATLAB Web App Server install directory.

Supported Browsers

Web apps are compatible with commonly used browsers like Google Chrome™, Safari, Firefox®, Microsoft Edge®.

For browsers that update automatically, the current stable version is supported.

Web apps are also supported on the Safari browser on iPads, and the Chrome™ browser on Chromebooks.

Platform Incompatibilities

MATLAB Web App Server cannot be installed on Ubuntu® 14.04 LTS or Red Hat® Enterprise Linux® 6.

* Linux systems require systemd to run MATLAB Web App Server software.

Introduced in R2020a

View requirements for another product: