Gtk-Message: 10:32:31.466: Failed to load module "canberra-gtk-module"

조회 수: 701 (최근 30일)
Xiao Wang
Xiao Wang 2019년 7월 17일
댓글: Terje Sparengen 대략 21시간 전
I installed matlab 2019a with update3 on ubuntu 16.04 64bit. When I run matlab, I got output: Gtk-Message: 10:32:31.466: Failed to load module "canberra-gtk-module".
How to sort this problem.
Thanks in advance.
  댓글 수: 3
Zachary LaFlair
Zachary LaFlair 2020년 11월 17일
For anyone still bashing their heads off the wall in 2020 on R2020b. I'm using Arch Linux on Gnome Xorg. Currently patched at Kernel 5.9.8. I installed from the MATLAB website and created a folder with user permissions in the default install folder. Then ran ./install.
Here's what i used.
I first had to install gtk-2 package from the official arch repos.
sudo pacman -S gtk-2 %it might have worked after this if i didn't mess with my java install so much trying to make it work
Next i had to rollback my java version...
java --version %I had absolutely blown away my java install at this point and grabbed many packages from AUR to no avail so i got the official repo package
sudo pacman -S jre8-openjdk % Installs java
sudo pacman -S jdk8-openjdk % Installs java
Finally set matlab to open with my known good/supported version
export MATLAB_JAVA=/usr/lib/jvm/java-8-openjdk/jre
matlab %%opens MATLAB window without issues or failures
% I can and did plot a polynomial just to make it work
% First plot polynomial code that shows up on google.
y_1 = @(x) -0.6729+4.8266*x-0.4855*x.^2+0.0312*x.^3
x_1 = 0:0.1:33.5;
plot(x_1,y_1(x_1))
Sam  Karan
Sam Karan 2024년 3월 12일
The error message "Gtk-Message: Failed to load module 'canberra-gtk-module'" indicates that the GTK library is unable to load the "canberra-gtk-module" module. This module is related to the GNOME Sound Theme support and is often used for playing sound events in GTK applications.
To resolve this issue, you can do one of the following:
  1. Install the 'libcanberra-gtk-module' package:Depending on your Linux distribution, you can install the required package. For example, on Debian-based systems (such as Ubuntu), you can use the following command:
sudo apt-get install libcanberra-gtk-module
On Red Hat-based systems (such as Fedora), you can use:
  1. sudo dnf install libcanberra-gtk2 libcanberra-gtk3
manatoki is the best website for free webtoons

댓글을 달려면 로그인하십시오.

답변 (12개)

Angel Palacios-Marin
Angel Palacios-Marin 2022년 6월 11일
편집: Angel Palacios-Marin 2022년 6월 11일
So the answer is in a terminal excecute the following
sudo apt-get install libcanberra-gtk* libgconf-2-4
sudo ln -s /usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so /usr/lib/libcanberra-gtk-module.so
The second line will create a link to the module. Matlab works with gtk-2.0 module. For other linux distributions follow this.
Problem solved, at least for me.
  댓글 수: 19
嘉祯
嘉祯 2024년 4월 4일 3:10
Thank you very much! It also works on Ubuntu20.04 with Matlab 2024a
Terje Sparengen
Terje Sparengen 대략 21시간 전
Thanks!
It works on Ubuntu22.04 with matlab R2020a

댓글을 달려면 로그인하십시오.


Scott Minkin
Scott Minkin 2019년 12월 15일
편집: Scott Minkin 2019년 12월 15일
I believe the canberra-gtk-module messages have no detrimental effect on MATLAB and can be ignored, but having said that...
To run MATLAB R2019a or R2019b on Ubuntu 16.04 LTS without the canberra-gtk-message:
You have three environmental variables that need to be set before running matlab
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
export LIBOVERLAY_SCROLLBAR=0
export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
OR you can run matlab in the bash shell by typing:
$ GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 LIBOVERLAY_SCROLLBAR=0 GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules /usr/local/MATLAB/R2019a/bin/matlab
----
To run R2019a on Ubuntu 18.04 LTS without the canberra-gtk-message:
You need to install libcanberra-gtk-module and libgconf-2-4
You don't need to set any environmental variables.
----
To run R2019b on Ubuntu 18.04 LTS without the canberra-gtk-message:
you need to install libcanberra-gtk-module
You have one environmental variable that needs to be set before running matlab:
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
OR you can run matlab in the bash shell by typing:
$ GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 /usr/local/MATLAB/R2019b/bin/matlab
Good luck.
  댓글 수: 6
ubaidulla
ubaidulla 2022년 3월 10일
This worked for me on ubuntu 20.04; Thank you
Julija Bucar
Julija Bucar 2023년 2월 26일
solution on arch was to export and set GTK_PATH to matlab executable

댓글을 달려면 로그인하십시오.


Xiao Wang
Xiao Wang 2019년 7월 18일
I did: sudo apt-get install libcanberra-gtk-module libcanberra-gtk0. But the error message is still there.
  댓글 수: 11
Maximilian Nentwich
Maximilian Nentwich 2021년 9월 9일
편집: Maximilian Nentwich 2021년 9월 9일
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
for MATLAB R2021a Update 4 and Ubuntu 20.04
Thank you!

댓글을 달려면 로그인하십시오.


Jan Studnicka
Jan Studnicka 2019년 10월 16일
See bug reports:
"On some Linux distributions, a message appears in the terminal window when starting MATLAB:
Gtk-Message: <timestamp>: Failed to load module "canberra-gtk-module"
and/or
Gtk-Message: <timestamp>: Failed to load module "pk-gtk-module"
This message is informational and has no effect on MATLAB."
  댓글 수: 3
Robert Eng
Robert Eng 2020년 11월 26일
I tried the work around suggested in the "bug report" from the above link. Did not fix the problem. I can use the matlab as is with the error but irritating to keep the terminal open and running otherwise Matlab closes
Nour
Nour 2022년 8월 11일
worked for me, thanks !

댓글을 달려면 로그인하십시오.


Frederico Azevedo
Frederico Azevedo 2019년 12월 14일
I had the same error with my R2019b installation in ubuntu 19.10. After I installed the module with "sudo apt install libcanberra-gtk-module -y", if I call matlab from the command line with the cmd "LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0/modules:$LD_LIBRARY_PATH /usr/local/bin/matlab", the error message doesn't appear anymore.

Kehelwala Dewage Gayan Maduranga
Kehelwala Dewage Gayan Maduranga 2020년 11월 18일
편집: Kehelwala Dewage Gayan Maduranga 2020년 11월 18일
I am installing matlab R2020b on Ubuntu 18.04 and having this error
Gtk-Message: 17:15:55.104: Failed to load module "canberra-gtk-module"
  댓글 수: 8
Imad Abied
Imad Abied 2021년 5월 27일
same on Ubuntu 20.04 and Matlab R2021A
Paul Galloux
Paul Galloux 2022년 2월 1일
export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0/modules:$LD_LIBRARY_PATH
before to launch matlab or put this line in your .bashrc
solve-it for me ub20.04

댓글을 달려면 로그인하십시오.


Chen Wang
Chen Wang 2019년 10월 12일
I have encountered the same problem....

Chen Wang
Chen Wang 2019년 10월 12일
Finally I solve this problem by change from 2019b to 2019a. The error message disappear. There must be something wrong with 2019b's Linux version.

Alex Pedcenko
Alex Pedcenko 2019년 11월 28일
this is not the "problem"

LeChat
LeChat 2020년 1월 16일
편집: LeChat 2020년 1월 16일
It had the same message and then I followed @Scott Minkin recommandation and I still have a message, but a different one:
me@myPC:~$ matlab &
[1] 22115
me@myPC:~$ Gtk-Message: 17:29:07.572: Failed to load module "canberra-gtk-module"
[0116/172911.622390:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
me@myPC:~$ export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
[1]+ Done matlab
me@myPC:~$ matlab &
[1] 29896
me@myPC:~$ [0116/173302.576327:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
I then tried this:
me@myPC:~$ sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcanberra-gtk3-module is already the newest version (0.30-7ubuntu1).
libcanberra-gtk-module is already the newest version (0.30-7ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
me@myPC:~$ matlab &
[2] 7532
me@myPC:~$ [0116/173838.654136:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
In both case Matlab 2019b is launched as expected but I am wondering if everything is ok because of the messages I keep having in the Terminal.
I am running Ubuntu 19.10. Thank you for your expertise.
  댓글 수: 3
Scott Minkin
Scott Minkin 2020년 4월 8일
Not sure why the pk-gtk-module warning is coming up. What is the value of $GTK_MODULES? And can you try blanking it out by setting GTK_MODULES=
GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 GTK_MODULES= matlab
Good luck.
--Scott
Manuel Mercier
Manuel Mercier 2020년 4월 16일
GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 GTK_MODULES = matlab
launch Matlab, and display
Failed to load module "pk-gtk-module"
in the console

댓글을 달려면 로그인하십시오.


Burcin Arici
Burcin Arici 2020년 4월 9일
I also get the same error message while running
Gtk-Message: 04:38:48.679: Failed to load module "canberra-gtk-module"
for Matlab R2020a on Ubuntu 19.10, it works slower than R2019b but untill now, during running the program, it does not give an another error.

Chase Philport
Chase Philport 2022년 12월 7일
Also having this error with my install

카테고리

Help CenterFile Exchange에서 Startup and Shutdown에 대해 자세히 알아보기

태그

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by