이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

프로젝트 종속성 분석하기

프로젝트 구조를 분석하고 프로젝트에 필요한 파일을 찾으려면 종속성 분석을 실행하십시오. 프로젝트에 필요한 파일이 모두 있는지 확인하려면 워크플로 중 언제든지 종속성 분석을 실행할 수 있습니다. 예를 들면, 특정 버전의 프로젝트를 소스 컨트롤에 제출하기 전이나 프로젝트를 공유하기 전, 또는 프로젝트를 설정할 때 종속성을 검사하는 것이 좋습니다.

종속성 분석을 실행하면 실제로 변경을 수행하기 전에 그 변경이 다른 파일에 어떤 영향을 주는지 알 수 있습니다. 예를 들어 프로젝트 구조를 살펴보거나 프로젝트 파일의 문제를 찾아 조사하고 해결할 때, 또는 프로젝트에 필요한 툴박스를 찾을 때 종속성 분석은 흔히 사용됩니다. 요구 사항 변경이 미치는 잠재적 영향을 조사할 때 종속성 분석을 실행하여 요구 사항 문서와 연결된 설계 파일을 찾을 수 있습니다. 또한 종속성 분석을 사용하여, 변경 사항을 커밋하기 전에 수정된 파일의 업스트림 및 다운스트림 종속성을 찾아 변경 사항이 미치는 영향을 조사할 수도 있습니다. 업스트림 및 다운스트림 종속성을 찾으면 수정이 필요한 설계 파일과 테스트 파일을 확인하고 실행해야 할 테스트를 찾는 데 도움이 됩니다.

종속성 분석이 끝나면 파일을 열거나 파일에 레이블을 지정할 수 있습니다. 또한 결과를 작업 공간 변수, 이미지 또는 다시 불러오기가 가능한 파일로 내보낼 수 있습니다. 이러한 파일은 사용자 지정 작업을 처리하기 위한 용도로 전송할 수 있습니다. 결과를 내보내면 영향 분석 결과를 추가 처리하거나 보관할 수 있습니다. 내보낸 파일 목록은 변경 사항이 미치는 영향을 설명한 리포트나 다른 문서에 추가할 수 있습니다.

종속성 분석 실행하기

프로젝트에 대한 종속성 분석을 실행하기 전에 프로젝트에 파일을 모두 추가했는지 확인하십시오. 종속성 분석은 프로젝트에 있는 파일만 검사합니다. 자세한 내용은 프로젝트에 파일 추가하기 항목을 참조하십시오.

프로젝트의 모든 파일을 대상으로 종속성 분석을 실행하려면 종속성 분석(Dependency Analysis) 보기를 선택하십시오. 그런 다음 종속성 분석(Dependency Analysis) 탭에서 분석(Analyze)을 클릭합니다.

특정 파일만 분석하려면 종속성 분석(Dependency Analysis) 탭에서 분석(Analyze) > 분석할 파일 선택(Select Files to Analyze)을 클릭하십시오. 분석할 파일을 선택한 다음 분석(Analyze)을 클릭합니다.

외부 툴박스의 종속성을 분석하려면 종속성 분석(Dependency Analysis) 탭에서 옵션(Options) > 외부 툴박스 분석(Analyze External Toolboxes)을 클릭하십시오.

종속성 분석이 끝나면 영향 보기(Impact View)에 다음과 같은 정보가 표시됩니다.

  • 프로젝트 구조와 프로젝트 파일의 종속성. 모델, 라이브러리, 함수, 데이터 파일, 소스 파일, 파생된 파일이 서로 어떻게 관련되어 있는지 보여줍니다.

  • 필요한 제품과 툴박스.

  • 소스 파일과 파생된 파일 간의 관계(예: .m 파일과 .p 파일, .slx 파일과 .slxp 파일, .ssc 파일과 .sscp 파일 또는 .c 파일과 .mex 파일)와 C/C++ 소스 파일과 헤더 파일 간의 관계. 각 모델에서 생성된 코드를 확인하고, 모델을 수정할 경우 재생성해야 하는 코드를 확인할 수 있습니다.

  • 문제 파일에 대한 경고(예: 누락된 파일, 프로젝트에 없는 파일, 변경 사항이 저장되지 않은 파일, 최신 버전이 아닌 파생된 파일).

프로젝트 종속성과 문제 파일을 살펴보려면 종속성 분석(Dependency Analysis) 보기의 오른쪽 상단에서 테이블 보기(Table View)를 클릭하십시오.

프로젝트에 대한 종속성 분석을 처음 실행하고 나면 이후 분석은 증분 업데이트로 진행됩니다. 그러나 외부 툴박스를 업데이트한 후 외부 툴박스의 종속성 변경 사항을 찾으려면 전체 분석을 수행해야 합니다. 전체 분석을 수행하려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 분석(Analyze) > 모두 다시 분석(Reanalyze All)을 클릭하십시오.

Simulink® 모델과 라이브러리를 대상으로 종속성 분석을 실행하는 방법에 대한 자세한 내용은 Perform Impact Analysis (Simulink) 항목을 참조하십시오.

문제 조사 및 해결하기

종속성 분석을 실행하고 나면 영향 보기(Impact View)에 전체 프로젝트에 대한 영향 그래프가 표시됩니다. 프로젝트 종속성 분석에서는 누락된 파일, 프로젝트에 없는 파일, 저장되지 않은 변경 사항, 최신 버전이 아닌 파생된 파일 등 다양한 문제를 식별합니다. 영향 보기(Impact View) 또는 테이블 보기(Table View)에서 문제 파일을 검토할 수 있습니다.

문제 파일을 그래픽 방식으로 살펴보려면 영향 보기(Impact View)를 사용하십시오. 보기의 가운데에 프로젝트에 대한 영향 그래프가 표시됩니다. 영향 보기(Impact View)의 오른쪽 패널에는 툴박스 종속성과 문제 파일의 목록이 표시됩니다.

  • 그래프에 문제 파일만 표시하려면 영향 보기(Impact View)의 오른쪽 창에 있는 문제(Problems) 제목에 커서를 올려놓고 모두 찾기(Find All)를 클릭하십시오. 전체 프로젝트 보기로 돌아오려면 검색 상자에서 필터를 지우십시오(예: Dependencies of "filename").

  • 특정 문제 파일의 세부 정보(예: 경로, 형식, 문제 메시지)를 보려면 그래프에서 해당 파일을 선택하십시오. 파일 선택을 지우고 프로젝트의 모든 문제 파일을 보려면 그래프의 빈 영역을 클릭하십시오.

  • 파일 종속성을 확인하려면 문제 파일에 커서를 올려놓고 모두 찾기를 클릭하십시오. 문제 파일과 문제 파일의 종속성만 표시하도록 그래프가 업데이트됩니다. 전체 프로젝트 보기로 돌아오려면 검색 상자에서 필터를 지우십시오(예: problem=='*').

프로젝트 종속성과 문제 파일을 테이블 형태로 살펴보려면 테이블 보기(Table View)를 사용하십시오. 테이블 보기(Table View)를 사용하려면 종속성 분석(Dependency Analysis) 보기의 오른쪽 상단에서 테이블 보기(Table View)를 선택하십시오.

  • 목록 맨 위에 있는 문제 파일을 보려면 문제 설명(Problem Description) 열을 기준으로 테이블을 정렬하십시오.

  • 파일의 문제를 보려면 해당 파일의 문제 설명(Problem Description) 열에서 메시지를 확인하십시오.

  • 파일의 종속성을 보려면 테이블에서 파일을 선택하십시오. 선택한 파일에 종속된 파일이 하단 창에 표시됩니다. 직접 영향을 받는 파일(Directly Impacted Files)을 보거나 직접 필요한 파일(Directly Required Files)로 전환할 수 있습니다.

문제 해결하기

각 문제 파일에 대해 문제 해결을 위한 조치를 취하십시오. 다음 표에는 흔히 발생하는 문제와 그 해결 방법이 나와 있습니다.

문제 메시지

설명

해결 방법

Not in project

파일이 프로젝트에 없습니다.

프로젝트에 파일을 추가합니다.

필요한 파일을 모두 프로젝트에 추가할 필요는 없습니다. 예를 들어, 프로젝트의 소스 코드가 생성하는 파생된 S-Function 이진 파일은 제외시킬 수 있습니다. 자세한 내용은 프로젝트에 파일 추가하기 항목을 참조하십시오.

파일을 프로젝트에 추가하지 않고 문제 목록에서 제거하려면 파일을 마우스 오른쪽 버튼으로 클릭한 다음 외부 파일 추가(Add External File)를 선택하십시오.

Missing project file

파일이 프로젝트에는 있지만 디스크에는 없습니다.

파일을 만들거나 소스 컨트롤을 사용하여 파일을 복구합니다.

Outside project root

파일이 프로젝트 루트 폴더 외부에 있습니다.

파일이 프로젝트 루트 폴더 외부에 있어도 괜찮다면 파일을 외부 파일로 설정하십시오. 그렇지 않으면 파일을 프로젝트 루트 아래로 옮기십시오.

프로젝트 루트 외부에 있는 파일을 프로젝트 내에 두어야 하는 경우 파일을 프로젝트 루트 안으로 복사하거나 옮긴 다음 프로젝트와 경로에 추가합니다. 경로에서 원래 파일 위치를 제거합니다.

필요한 파일이 프로젝트 루트 외부에 있는 경우 이러한 파일은 프로젝트에 추가할 수 없습니다. 파일이 경로에 있고 프로젝트에 포함되지 않은 유틸리티 또는 리소스에 해당하는 경우 이러한 종속성은 문제를 나타내는 것이 아닐 수 있습니다. 종속성 분석을 사용하여 설계 종속성을 확실히 파악할 수 있습니다.

In unreferenced project

파일이 현재 프로젝트에서 참조되지 않은 프로젝트에 있습니다.

해당 파일이 포함된 프로젝트를 프로젝트 참조로 추가합니다.

Missing file

파일 또는 변수를 찾을 수 없습니다.

이 문제 상태를 인정한다면 파일을 마우스 오른쪽 버튼으로 클릭한 다음 외부 파일 추가(Add External File)를 선택하십시오.

Unsaved changes

파일에 MATLAB® 편집기의 저장되지 않은 변경 내용이 있습니다.

파일을 저장합니다.

Derived file out of date

파생된 파일이, 파일이 파생된 소스 파일보다 이전 버전입니다.

파생된 파일을 다시 생성합니다. 파생된 파일이 .p 파일인 경우 프로젝트 검사를 실행하여 자동으로 파일을 다시 생성할 수 있습니다. 프로젝트(Project) 탭에서 프로젝트 검사(Check Project)를 클릭한 다음, 표시되는 프롬프트 내용에 따라 파일을 다시 빌드합니다.

소스 파일의 이름을 바꿀 경우 프로젝트는 파생된 파일에 미치는 영향을 감지하고 파생된 파일을 업데이트하라는 메시지를 표시합니다.

Missing product

프로젝트에 누락된 제품에 대한 종속성이 있습니다.

누락된 제품을 설치합니다.

필요한 툴박스 찾기

프로젝트에 대한 종속성 분석을 실행하고 나면 전체 프로젝트 또는 선택한 파일에 필요한 툴박스가 영향 보기(Impact View)에 표시됩니다. 제품을 사용하는 데 필요한 제품을 확인하거나 제품 종속성을 야기하는 파일을 찾을 수 있습니다.

종속성 분석(Dependency Analysis) 보기의 오른쪽 창에 있는 제품(Products) 섹션에 전체 프로젝트에 필요한 제품이 표시됩니다. 선택한 파일에 필요한 제품을 보려면 그래프 또는 범례를 클릭하여 파일을 선택하십시오.

제품 종속성을 야기하는 파일을 찾으려면 제품 이름에 커서를 올려놓고 사용 사례 찾기(Find Usages)를 클릭하십시오.

선택한 제품을 사용하는 파일만 표시하도록 그래프가 업데이트됩니다. 전체 프로젝트 보기로 돌아오려면 검색 상자에서 필터를 지우십시오(예: Usages of "productname").

필요한 제품이 누락된 경우 제품 목록에서 누락됨(Missing)으로 레이블이 지정되어 있습니다. 누락된 제품 문제를 해결하려면 제품을 설치하고 종속성 분석을 다시 실행하십시오.

파일 종속성 찾기

종속성 분석 실행 후 파일 종속성을 검토하려면 영향 보기(Impact View)의 그래프에서 파일을 마우스 오른쪽 버튼으로 클릭한 다음, 모든 종속 관계 찾기(Find All Dependencies), 영향받는 파일 찾기(Find Impacted Files) 또는 필요한 파일 찾기(Find Required Files)를 선택하십시오. 선택한 파일과 파일 종속성이 그래프에 표시됩니다.

또는 파일을 선택하고 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 영향 분석(Impact Analysis) 섹션에서 찾기(Find)를 클릭할 수도 있습니다. 사용 가능한 옵션 중에서 선택합니다.

파일 그룹을 선택하려면 영향 보기(Impact View)의 왼쪽 위 코너에 있는 파일 형식(Save as type) 범례에 있는 사용 가능한 옵션 중에서 선택하십시오. 예를 들어, 함수 파일을 모두 선택하려면 파일 형식(Save as type)을 클릭한 다음 함수(Function)를 선택하십시오. 보기에서 파일이 그룹화되는 방식을 변경하려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 보기(View) 섹션에서 그룹화 기준(Group By)을 클릭하십시오. 사용 가능한 옵션 중에서 선택합니다.

수정된 파일, 문제 파일 또는 외부 파일을 선택하려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 영향 분석(Impact Analysis) 섹션에서 선택(Selection)을 클릭하십시오. 사용 가능한 옵션 중에서 선택합니다.

파일 종속성을 검토하거나 편집하려면 그래프에서 파일 이름 옆에 있는 화살표를 클릭하여 파일을 확장하십시오. 그런 다음 참조 구성요소(예: 문제 파일을 참조하는 MATLAB 코드 라인)를 더블 클릭하여 엽니다. 그래프에서 모든 파일을 확장하려면 보기(View) 섹션에서 모두 확장(Expand All)을 클릭하십시오.

프로젝트에서 분석한 모든 종속성을 표시하도록 그래프를 재설정하려면 종속성 분석(Dependency Analysis) 탭의 영향 분석(Impact Analysis) 섹션에서 찾기(Find) > 모든 파일(All Files)을 선택하십시오.

대형 프로젝트인 경우 결과를 테이블로 보면 더 쉽게 살펴볼 수 있습니다. 테이블 보기(Table View)를 사용하려면 종속성 분석(Dependency Analysis) 보기의 오른쪽 상단에서 테이블 보기(Table View)를 선택하십시오.

요구 사항 문서 찾기

프로젝트에서 종속성 분석을 실행하면 RMI(Requirements Management Interface)를 사용하여 연결된 요구 사항 문서를 찾을 수 있습니다.

  • 연결된 요구 사항 문서를 보거나 탐색할 수 있습니다.

  • Simulink Requirements™가 있는 경우에만 Requirements Management 링크를 만들거나 편집할 수 있습니다.

그래프에서 요구 사항 문서를 강조 표시하려면 영향 보기(Impact View)의 오른쪽 상단에서 종속 관계 유형(Dependency Type) 범례를 클릭한 다음 Requirements Link를 선택하십시오. 화살표는 요구 사항 문서를 요구 사항 링크가 포함된 파일에 연결합니다.

특정 파일에 대한 요구 사항 링크를 찾으려면 그래프에서 파일 이름 옆에 있는 화살표를 클릭하여 파일을 확장하십시오. 그래프에서 모든 파일을 확장하려면 보기(View) 섹션에서 모두 확장(Expand All)을 클릭하십시오. 화살표는 요구 사항 링크가 포함된 구성요소와 요구 사항 문서를 연결합니다.

요구 사항 문서를 열려면 그래프에서 문서를 더블 클릭하십시오.

종속성 분석 결과 저장, 열기, 비교하기

프로젝트에서 종속성 분석을 실행한 후 분석 결과를 저장할 수 있습니다. 그러면 결과를 열고 볼 수 있기 때문에 분석을 반복할 필요가 없습니다.

결과를 .graphml 파일로 저장하려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 파일(File) 섹션에서 다른 이름으로 저장(Save As)을 클릭하십시오. 파일 이름과 위치를 선택합니다.

저장된 종속성 분석 결과를 열려면 종속성 분석(Dependency Analysis) 탭의 파일(File) 섹션에서 열기(Open)를 클릭하십시오.

현재 종속성 분석 결과를 이전에 저장한 결과와 비교하려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 파일(File) 섹션에서 저장된 분석과 비교(Compare to Saved)를 클릭하십시오. .graphml 파일을 선택하고 비교 리포트에서 차이점을 살펴봅니다.

영향 보기에서 파일 내보내기

종속성 분석의 영향 보기(Impact View)에 표시된 모든 파일을 내보내려면 먼저 그래프 배경을 클릭하여 모든 파일에 대한 선택을 취소하십시오. 그런 다음 종속성 분석(Dependency Analysis) 탭으로 이동한 후, 영향 분석(Impact Analysis) 섹션에서 내보내기(Export)를 클릭합니다. 사용 가능한 다음 옵션 중에서 선택하십시오.

  • 작업 공간에 저장(Save to workspace) — 선택한 파일 경로를 변수에 저장합니다.

  • 사용자 지정 작업으로 보내기(Send to Custom Task) — 파일이 선택되어 있는 사용자 지정 작업 대화 상자를 엽니다.

  • 파일 보기로 표시(Show in Files View) — 파일이 선택되어 있는 파일(File) 보기로 전환합니다.

그래프에서 일부 파일을 내보내려면 파일을 선택한 다음 내보내기(Export)를 클릭하십시오. 메뉴에 다음과 같은 정보가 표시되므로 몇 개의 파일을 선택했는지 알 수 있습니다. 선택한 파일: 파일 개수(Selected files: number of files) 또는 선택한 파일을 마우스 오른쪽 버튼으로 클릭한 다음 내보내기(Export) 메뉴에서 옵션을 선택할 수도 있습니다.

그래프를 이미지 파일로 내보내기

영향 보기(Impact View) 그래프를 공유하거나 보관하기 위해 이미지 파일로 내보내려면 종속성 분석(Dependency Analysis) 탭으로 이동한 다음 파일(File) 섹션에서 다른 이름으로 저장(Save As) > 이미지로 저장(Save As Image)을 선택하십시오. 저장 대화 상자에서 이름, 파일 형식, 위치를 지정합니다. 디폴트 파일 형식은 이미지 스케일링을 지원하는 SVG입니다.

키보드를 사용하여 이미지를 클립보드에 복사할 수도 있습니다. 그런 다음 클립보드 내용을 다른 문서에 붙여 넣을 수 있습니다.

관련 항목