Why do I get a connection error when installing or activating MATLAB or other MathWorks products?

조회 수: 10,567(최근 30일)
MathWorks Support Team
MathWorks Support Team 2013년 1월 3일
댓글: Jan 2022년 6월 12일 11:26
I get an error that I cannot connect to MathWorks when running the MathWorks installer or the activation client; however, I can access the website. Why can't the MathWorks Installer or activation client connect to the MathWorks?
Connection Error
The application could not connect to MathWorks.
For more information on resolving this issue, see this Support Article.

채택된 답변

MathWorks Support Team
MathWorks Support Team 2022년 4월 28일
편집: MathWorks Support Team 2022년 4월 28일
Computer or network security software is preventing the MathWorks Installer and/or Activation Client from connecting to the MathWorks servers. This is known as a connection issue due one or more of the following: 
  • Antivirus Software
  • Proxy
  • Firewall

Antivirus Software

To temporarily disable your Antivirus on Windows:
  1. Locate the Antivirus protection program icon on the Windows system tray.
  2. Right-click the icon and select Disable, Stop, etc. to temporarily disable the program. In some cases, you may need to open the program and disable it using the program's menus.
 To temporarily disable your Antivirus on a Mac:
  1. Locate the Antivirus icon found on your Mac menu bar.
  2. Click Shut down or disable temporarily until installation and activation have completed.
To temporarily disable your Antivirus on a Linux:
  1. Locate the Antivirus protection program icon on the Linux system tray.
  2. Click Shut down or disable temporarily until installation and activation have completed.

Proxy

The MathWorks installer, activation client and update installer will try to automatically inherit your user proxy settings on Windows and MacOS.
To disable your Proxy in Internet Explorer:
  1. Click the Tools button and then select Internet Options.
  2. Click the Connections tab and then select LAN settings.
  3. Uncheck the check box for Use a proxy server for your LAN.
To disable your Proxy in Chrome:
  1. Open the Customize and Control Google Chrome menu by clicking on the three-dots icon at the top right of Google Chrome, select Settings on the right, find Advanced and finally select open proxy settings.
  2. Select the LAN Settings button.
  3. Deselect the checkbox for Use a proxy server for your LAN.
To disable your Proxy in Safari:
  1. Go to Menu and click on Preferences from the drop-down menu.
  2. Select the Advanced tab and then click on the Change Settings button.
  3. Deselect the checkbox for Use a proxy server for your LAN.
To disable your Proxy in Firefox:
  1. Click the Tools button and select Options.
  2. Go to the Advanced panel and select the Network tab.
  3. Click on Settings in the Connection Section and select No Proxy.
You will need to contact your IT Help Desk to troubleshoot this issue if you don't know your proxy settings or the error persists after entering your proxy settings. 

Firewall

You will need to contact your IT Help Desk if your organization is running a network firewall to configure it to bypass blocked connections to the MathWorks servers.The MathWorks installer needs to contact MathWorks servers on the following ports and addresses:
  • login.mathworks.com
  • services.mathworks.com
  • TCP ports 80 and 443
Your firewall needs to bypass blocked connections for both addresses over both ports. These servers do not use a Static IP Address and will resolve to a Dynamic IP Address. This means that users will not be able to white-list MathWorks servers via IP Address and will have to use the domain name. 

Offline procedures

To bypass connection errors when installing or activating MATLAB, you may perform an offline installation or activation. For instructions on performing either, please refer to the relevant support article before:
For information on performing an offline installation of an update or support package:

Contact US

If the MathWorks installer is still unable to connect after troubleshooting, and you would like further assistance with resolving the connection error, submit a service request.  Please include the troubleshooting steps you took to resolve the connection issue and include your installation log file. See this related article if you require assistance locating your log file:
  댓글 수: 40
昀琪 蔡
昀琪 蔡 2022년 4월 21일
이 댓글에 1명의 참여자가 플래그를 지정함
关掉安全卫士的阻挡就可以了!!!关掉以后需要等五六分钟再试一次

댓글을 달려면 로그인하십시오.

추가 답변(74개)

Sean
Sean 2014년 7월 30일
When I received this error, it was not due to proxy settings or firewall settings. Rather, when I downloaded the installer, the download location was on a remote drive (a windows remote profile DFS location). I copied the setup file to the local drive, and it ran fine.
  댓글 수: 18

댓글을 달려면 로그인하십시오.


Brett Hansell
Brett Hansell 2019년 10월 8일
  1. Under System Variables, select New.
  2. Set the first variable name "JAVA_TOOL_OPTIONS" with the value of "-Djava.net.preferIPv4Stack=true" (enter these without the quotation marks)
  3. select New again.
  4. Set the second variable name "JAVA_OPTIONS" with the value of "-Djava.net.preferIPv4Stack=true" (enter these without the quotation marks) and click on OK
  5. Click OK again on the previous screen and try the installer again.
  댓글 수: 14

댓글을 달려면 로그인하십시오.


Brian Zarling
Brian Zarling 2015년 2월 16일
I turned off my firewall and I still can't connect to Mathworks.
  댓글 수: 6
Daniel Torres
Daniel Torres 2020년 8월 26일
I was getting installation errors left and right. I did an internet speed test and saw I was pulling only 10MB. I relocated my wireless dongle, retested, 150MB. Tried again - installed successfully.
Seems the installer is persnickity with your download speeds.

댓글을 달려면 로그인하십시오.


khalid Houhou
khalid Houhou 2018년 2월 28일
I had this issue and it was not related to any network or connection. It was caused by a Malware I had in my PC called relevantknowledge. I uninstall it and it worked.
  댓글 수: 10

댓글을 달려면 로그인하십시오.


Gregg Casey
Gregg Casey 2017년 12월 29일
Had the same problem on my Mac and I have never had a problem like this on a Mac since I have used them. (Probably more than 8 years.) My laptop did not have the firewall turned on at all during all attempts. So this is probably just badly written software from Mathworks. What worked for me is to use my hotspot. That is all I changed - connect to my Karma hotspot and click "Next" again. Done. Note that I first did the same after connecting to my iPhone as a hotspot and that did not work. (Just clicked "next" and got the same error message.) However, that could have been that my phone was having a connection issue.
Mathworks- please look into this issue and fix it. The software should not require special proxy settings.
  댓글 수: 4
Sam Kovnar
Sam Kovnar 2022년 3월 10일
I had pretty much the same issue. Went through all the previous solutions, nothing worked. I was on a 5G network, so I switched to a different one and it worked fine. No idea why this fixed it, but I'm just happy it worked. It wasn't an internet connectivity thing - if anything, the second network I tried was a little bit slower than the previous one.

댓글을 달려면 로그인하십시오.


Chris Håkansson
Chris Håkansson 2015년 2월 23일
I had the same problem and followed all instructions above about filling in proxy-server information and deactivating the firewall etc. but nothing worked. Turned out all I needed to do was uncheck the box which indicates to use a proxy server. It is as mentioned in other links found in Control Panel/Internet Options/Connections/Lan Settings.
  댓글 수: 4

댓글을 달려면 로그인하십시오.


Yehya Jebbaoui
Yehya Jebbaoui 2017년 9월 28일
Turn off the Wifi of the institution you are in, then turn on Mobile hotspot on your phone to share the mobile connection (if you have 3G or 4G). You will pass the first steps and it will start downloading. When it starts downloading, switch to the wifi. It worked for me.
  댓글 수: 6

댓글을 달려면 로그인하십시오.


Caitlyn Hampel
Caitlyn Hampel 2015년 5월 24일
I had this problem as well, but I found that it was because my internet connection was too slow. So it only worked when I used a faster connection. Beware that the downloads during installation are rather large files, including the toolbox add-ons. Hope this information can be of help to others.
  댓글 수: 3

댓글을 달려면 로그인하십시오.


Jon
Jon 2014년 12월 16일
On a Mac (running 10.10 [Yosemite]) I still needed to temporarily disable the Firewall (under System Preferences > Security & Privacy) in order to complete activation.

Donald Niman
Donald Niman 2015년 2월 23일
This is what I did to successfully install Matlab (Home Use) on my Windows 7 x64 SP1 system. Note that I do not know which one of the following things helped to make things work; I just did all of them. Also note that I am not using a proxy server, if you are, this will probably not help you.
1. Turned off internet router and then turned it back on.
2. Restarted the PC in Safe Mode.
3. If applicable to you: The installation file was on hard drive volume D:\ and I moved it to C:\
4. From control panel->administrative tools->Services, I right-clicked "Windows Firewall" and selected "Stop".
5. I ran the Matlab installation file from c:\.
6. When the installation screen came up, I did not click on the button at the top right of the dialog. Instead, I clicked the "next" button at the bottom. (Of course, I am not using a proxy server.)
7. A dialog appears to enter your login credentials: do that and the installation will continue.
8. The installation will eventually complete and then you can activate it by following the on-screen directions.
9. I restarted the system normally and verified that Matlab was working.
(Hopefully, I did not leave anything out.)
  댓글 수: 4

댓글을 달려면 로그인하십시오.


Anna Smirnova
Anna Smirnova 2018년 7월 1일
Error : unable to connect to host. sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Windows 7 64-bit. What am I doing wrong?

Matthias Finsterbusch
Matthias Finsterbusch 2018년 7월 2일
I am trying to install Matlab 2018b on a Win10 64bit System, getting the following error:
"Error : unable to connect to host. sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"
Any instructions how to handle this problem? Thanks in advance.

Jan
Jan 2019년 3월 14일
Create the two environment variables
  • "JAVA_TOOL_OPTIONS" with the value "-Djava.net.preferIPv4Stack=true"
  • "JAVA_OPTIONS" with the value "-Djava.net.preferIPv4Stack=true"
Run the installer. Afterwards the variables can be removed.
  댓글 수: 3
Ani Padma
Ani Padma 2020년 7월 11일

Thanks a lot Jan, I tried all other suggested solutions with no success...I was even considering upgrading my laptop to a new one thinking it might be a hardware issue.However, this environment variables solution worked for me...Phew!!

댓글을 달려면 로그인하십시오.


Jiawei Meng
Jiawei Meng 2020년 5월 15일
Guys, I just tried 16 times....Yes, I counted it and now it works. So don't give up....
However, I don't whether it is because my internet connection is bad or not? Because I literally changed nothing....

Dewi Mar'a
Dewi Mar'a 2018년 11월 20일
I am dealing with the same problem. After almost a week I tried to install matlab more than hundred times, then I got no solution at all. My windows firewall was off, no proxy setting, no anti virus installed, even no matlab installed yet.
I am getting deperate with this problem because my deadline project comes closer, and I wasted the time too much to deal with this problem.
finally I end up with the last solution left, I tried to uninstall my windows, and try to install matlab again. BAAAAMMM....it works. do anything to get out of this stuck step. if it ends with great result, why not ? haha
  댓글 수: 1
lin hv
lin hv 2019년 8월 16일
I feel so sorry about that. I am still through this annoying problem, yet I have to spend my time on those matter more.

댓글을 달려면 로그인하십시오.


ismail tepedag
ismail tepedag 2019년 1월 14일
Hey guys, I read everything and closed antivirus , firewall etc...
Then it did not work.
I tried repeatedly some 10 times then it worked miracleously. ?!
As a result, try try try...

Ceren Yurdakul
Ceren Yurdakul 2021년 1월 3일
I had the connection error. I literally tried every solution that people suggested above for days and non of them worked for me. I finally solved it like this:
I connected to the celluar data from my phone instead of WiFi. After using my phone's internet I chose my destination file and clicked next, it started downloading. Then I changed back to WiFi to avoid wasting my phone's internet and it continued downloading anyway.
That's how I fixed my connection error. I hope it works for yu too.

Christopher Silva
Christopher Silva 2021년 4월 12일
I tried absolutely all the solutions that were up but nothing worked for me (I have macOS Catalina 10.15.7). However, what apparently worked for me was very simple. All you have to do is go to "System Preferences", then go to the logo "Java" (if you don’t have Java, download it here: https://www.java.com/en/download/). After that, a configuration window will open, then you go to "General", then "Network Settings" and change it to "Direct Connection".
Pd: make sure you update Java before this.
Pd2: if like me, you tried all (literally all) the solutions in the above entries and nothing worked, and this solution either did or did not serve you because it was already configured with "Direct Connection", I think you should contact mathworks support.

Walter Roberson
Walter Roberson 2021년 4월 17일
Data point for MacOS Catalina:
I have not had difficulty downloading or authenticating to Mathworks until just now. I was installing R2017b onto MacOS Catalina; the download worked, but when I went to register the license, it gave me an error message (that linked to this topic.)
I looked in MacOS security settings, and reviewed everything, but did not find anything relevant. I did happen to notice that my Kensington Trackball manager was blocked from accessing the network, so I authorized that, but I really doubt that made any difference.
I went back to try the authentication again, and this time it worked without problem.
I don't think authorizing the trackball was at all relevant; I think it was just the trying again that made the difference.
  댓글 수: 1
Walter Roberson
Walter Roberson 2021년 4월 25일
I just had the same problem for R2016a -- first authentication attempt said that it could not connect to Mathworks, second authentication attempt worked fine.

댓글을 달려면 로그인하십시오.


jynik
jynik 2021년 9월 30일
편집: jynik 2021년 9월 30일
I have created a workaround for this issue that is more approprate for fellow Linux users of older MATLAB releases. (I have up to R2017a.)
As noted in my earlier post, I believe this issue (at least one cause of it as of today) is an incompatibility in the TLS version/cipher suites supported in the Java environment bundled in older installers, versus the those required by the CDN servers MathWorks is using for downloads. However, the way I circumvented TLS failures to investigate this is not an appropriate methodology for others to use, as it inherently suppresses very important security verification failues that would occur if someone were performing a MitM attack.
Instead, following scipt leverages the OpenJDK 8 Java already installed on an Ubuntu 20.04.2 LTS system. If my assment of the problem is indeed correct, then the idea is that this already includes the neccessary TLS >= 1.2 cipher suite support in order to make the connection to esd.mathworks.com.
The workaround procedure is as follows:
  • Install openjdk-8-jre on your system. On Ubuntu 20.04.2 LTS this can be done via: sudo apt install openjdk-8-jre
  • Note: OpenJDK >= 11 will not work due to java.xml.bind deprection
  • Start the MATLAB installer via: ./install -v
  • Close the installer now that it has unpacked files.
  • Make note of the JRE_LOC path that is printed, as this where installer files have been unpacked.
  • Edit the provided script to update items marked "CHANGEME" appropriately.
  • Run the script, which should launch the MATLAB installer using the system's Java installation.
  • With any luck, your "Conntection failed" error is gone.
  • You presumably now have multiple Java installations on your machine. Be aware of that, should it then become a root cause of a completely different issue. ;)
The script is pasted below and availble as a GitHub gist