R2020b: Custom Simulink Library appears empty in Simulink Library Browser

조회 수: 2 (최근 30일)
We work collaboratively on a Simulink Project and have a custom Library. We started work with R2019a and have since upgraded to R2020b.
We have top level library that contains subsystems linking to sub-libraries. In R2019a creating a new empty library, saving it with contents and a unique name (e.g. "LIB_somethingOrAnother") worked well. Next we create a subsystem in the top level library and set open callback to open sub library.
Custom Libraries created in R2020b appear to be empty when opened in the Simulink Library Browser. When you open them in Simulink, the blocks are there.
I just want to understand if we do something wrong or if this is a bug.
Thank you.

채택된 답변

Laurent Dalbies
Laurent Dalbies 2021년 3월 15일
I solved it by setting the EnableLBRepository option of the sublibraries, check here https://fr.mathworks.com/help/simulink/ug/adding-libraries-to-the-library-browser.html
What's strange is that I don't remember having set this option in R2019b for the sublibrary that was displayed in the browser.
  댓글 수: 1
Tobias Panitz
Tobias Panitz 2021년 3월 16일
편집: Tobias Panitz 2021년 3월 16일
You are the best!
Thank you
I am certain I have never done this before...

댓글을 달려면 로그인하십시오.

추가 답변 (0개)


Help CenterFile Exchange에서 Programmatic Model Editing에 대해 자세히 알아보기

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by