Failed to Launch Gazebo Simulation Environment

조회 수: 44(최근 30일)
Van Chuong Nguyen
Van Chuong Nguyen 2021년 2월 1일
댓글: shengqi xu 2021년 2월 27일
Hi all,
I am following this post to perform co-simulation between Simulink and Gazebo
I am using Virtual Machine to launch Gazebo Simulation Environment
After I open a terminal in the VM, run the following commands to launch the Gazebo simulator.
cd /home/user/src/GazeboPlugin/export
export SVGA_VGPU10=0
gazebo ../world/multiSensorPluginTest.world --verbose
Then I got the following error:
Unable to parse model.config for model[http://gazebosim.org/models/bin_4_dropping_task
I checked this error in many website sources but still not figured out.
I'd highly appreciate if you can give me some insights to fix this issue.
Thank you so much!
  댓글 수: 1
shengqi xu
shengqi xu 2021년 2월 27일
same question, and then i used "Gazebo subscribe block" to subscribe the topic that i published in gazebo(Ubuntu), the "block" can not get any topic from gazebo, although i could see all the topic in ubuntu "gz topic -l"

댓글을 달려면 로그인하십시오.

답변(1개)

Gaurav Bhosale
Gaurav Bhosale 2021년 2월 2일
편집: Gaurav Bhosale 2021년 2월 2일
Hi Van,
The shipped VM contains older Gazebo version and RAM is limited to 2GB.
Can you please try following two things,
1] Upgrade Gazebo version to latest ( mostly 9.16 )
sudo apt-get install gazebo=9.16
2] Change RAM to 4GB from VM settings.
Please let me know, if you still face same issue.
Thanks.
  댓글 수: 3
Van Chuong Nguyen
Van Chuong Nguyen 2021년 2월 4일
Thanks Gaurav,
I just tried sudo apt-get install gazebo=9.16, but it shows
E: Unable to locate package gazebo
Do you know why? Thank you.

댓글을 달려면 로그인하십시오.

제품


릴리스

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by