Matlab gives "ContributedToolsLoader" error

조회 수: 25(최근 30일)
Baran Ozvaris
Baran Ozvaris 2020년 10월 21일
댓글: Stanislas Dumas 2020년 12월 17일
Whenever I try to open Matlab, it throws error as below. I just downloaded the app, and try to open a m file.
Also, I added screnshot as well.
PC is Macbook Pro Catalina version 10.15
Exception in thread "ContributedToolsLoader": java.lang.NoClassDefFoundError: Could not initialize class java.nio.file.FileSystems$DefaultFileSystemHolder
at java.nio.file.FileSystems.getDefault(FileSystems.java:176)
at java.io.File.toPath(File.java:2234)
at com.mathworks.resources_folder.ResourcesFolderUtils.getResourcesFolderName(ResourcesFolderUtils.java:31)
at com.mathworks.mde.desk.ContributedTools.constructToolSetFileName(ContributedTools.java:103)
at com.mathworks.mde.desk.ContributedTools.<init>(ContributedTools.java:65)
at com.mathworks.mde.desk.ContributedToolsLoader$3.run(ContributedToolsLoader.java:69)
at java.lang.Thread.run(Thread.java:748)
Exception in thread "Startup Class Loader": java.lang.NoClassDefFoundError: Could not initialize class com.mathworks.instutil.InstutilResourceKeys
at com.mathworks.mlwidgets.help.DocCenterRoot.initDocRelease(DocCenterRoot.java:44)
at com.mathworks.mlwidgets.help.DocCenterRoot.<clinit>(DocCenterRoot.java:26)
at com.mathworks.mlwidgets.help.HelpPrefs.<clinit>(HelpPrefs.java:57)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at com.mathworks.mlservices.MLHelpServices.getDocRoot(MLHelpServices.java:522)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.getDocrootDirectory(ProductInfoUtils.java:707)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.getAbsolutePath(ProductInfoUtils.java:694)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.parseFile(ProductInfoUtils.java:259)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.parseFiles(ProductInfoUtils.java:319)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.pathChanged(ProductInfoUtils.java:154)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.<init>(ProductInfoUtils.java:80)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.getAllProductsInfo(ProductInfoUtils.java:900)
at com.mathworks.mlwidgets.util.productinfo.ProductInfoUtils.<clinit>(ProductInfoUtils.java:66)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at com.mathworks.mde.desk.StartupClassLoader$LoadInfo.<init>(StartupClassLoader.java:112)
at com.mathworks.mde.desk.StartupClassLoader.createLoadInfos(StartupClassLoader.java:202)
at com.mathworks.mde.desk.StartupClassLoader.access$500(StartupClassLoader.java:25)
at com.mathworks.mde.desk.StartupClassLoader$2.run(StartupClassLoader.java:223)
at java.lang.Thread.run(Thread.java:748)

답변(2개)

Prabhanjan Mentla
Prabhanjan Mentla 2020년 10월 28일
Hi,
MATLAB is compatible with Catalina version 10.15 from release R2019b onwards. This link may help you to understand system requirements and this to resolve specific error.
Hope this helps.

Jonathan Weaver
Jonathan Weaver 2020년 11월 30일
편집: Jonathan Weaver 2020년 11월 30일
I have the same error. It just started - I've been running 2020b for some time with no issue! Tried remove/reinstall but the issue is still there.
  댓글 수: 2
Stanislas Dumas
Stanislas Dumas 2020년 12월 17일
I got the exact same prblem starting today, still works fine on an old computer, was working fine today until it broke all of a sudden (I didn't update or change anything)

댓글을 달려면 로그인하십시오.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by