Problem sending data from ThignSpeak to Simulink

조회 수: 2 (최근 30일)
Vinicio Moya
Vinicio Moya 2020년 7월 7일
댓글: Vinicio Moya 2020년 7월 9일
I have a channel in ThingSpeak. Field number 4: Temperature, with some data. But, when I try to read that data in Simulink, I only receive 0... What could be happening?
Simulink model:
Configuration in simulink
ThingSpeak data:
  댓글 수: 2
Christopher Stapels
Christopher Stapels 2020년 7월 7일
Are you sure the R Pi is connected to the WiFi? What is the value at the status output?
Vinicio Moya
Vinicio Moya 2020년 7월 7일
Yes! I’m sure... I’m receiving the data... but always is zero...

댓글을 달려면 로그인하십시오.

채택된 답변

Reeno Joseph
Reeno Joseph 2020년 7월 9일
Hello Vinicio,
I just tried to read from your thingspeak channel and got the data. I ran the model in “Monitor & Tune” mode and could see the data. Please check the attachment.
To confirm the issue at your end please share the output of status port and the ‘Diagnostic viewer’
Reeno Joseph
  댓글 수: 1
Vinicio Moya
Vinicio Moya 2020년 7월 9일
I had to reinstall the Run Hardware Pi package and it works... Thanks!

댓글을 달려면 로그인하십시오.

추가 답변 (2개)

Vinicio Moya
Vinicio Moya 2020년 7월 7일
I´m trying with another blocks, and with this one, it is working. But, I need send this to run over a Raspberry Pi, and I can not use the ThingSpeak Input block. But, here is obviusly that the problem is in the Raspberry Pi ThingSpeakRead block...

Vinicio Moya
Vinicio Moya 2020년 7월 8일
On the other hand, if I use Raspberry Pi ThingSpeak Write block, it is sending all the time a 0. When manually I change that value with a 20, the system write a 20... But, the value of the constant in the left side is just like it doesn´t exists.


더 많은 답변 보기:  ThingSpeak 커뮤니티


Help CenterFile Exchange에서 Simulink Support Package for Android Devices에 대해 자세히 알아보기




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by