MATLAB Answers

0

MatLab Mex file generation, MatLab install issue?

Lucas 님이 질문을 제출함. 20 Aug 2012
This is probably a simple question but I wanted to verify the problem before I sent in the service request. We're running on MatLab 2012a, soon to be 2012b, and we have several machines on windows XP (32-bit) and a few on windows 7 (64-bit) and we noticed that our mex files from the 32-bit system doesn't work on the 64-bit system. We installed the .net framework and microsoft sdk so we can recompile the mex files on the 64-bit system, but we haven't been able to recompile them properly. We get an error when we try to set the compiler for the mex file.
It says that an error occurred and that our installation is incomplete. To make sure the .net framework is installed correctly before reinstalling the sdk. But we reinstalled everything making sure that the 64-bit version was checked and still that same error, so I was wondering if it could be with how we have MatLab installed? We have floating licenses on a network that we use, and I didn’t know if when you installed MatLab if there was settings that you had to check for the 64-bit version that might have not been checked or if MatLab installs both versions automatically and that I should be looking else-ware for the problem.
I can’t install the programs on the computers so I can’t tell if human error is the cause or not, but everything works on the 32-bit computers and nothing works on the 64-bit ones. So I wanted to know more about installing a 64-bit version of MatLab, so I can see if we can determine the problem or not. Thanks.

  댓글 수: 0

로그인 to comment.

답변 수: 1

Jan 님의 답변 21 Aug 2012
 채택된 답변

There have been problems repeatedly in the last year to install the 64-bit MSVC compilers. The order of the MSVC and SDK installation mattered and for some versions manual changes in the environment variables have been required. The documentation Supported Compilers claimed:
Both Microsoft Visual Studio 2008 and Windows Software Development Kit (SDK) 6.1 must be installed. When installing Microsoft Visual Studio, you must choose "X64 Compilers and Tools" when installing Microsoft Visual Studio; this is not selected by default.
But I'm sure the SDK7.1 is meant.
Finally I suggest to contact the technical support.

  댓글 수: 0

로그인 to comment.



Translated by