MATLAB Answers

0

Cannot connect to ROS device

In Ubuntu 16.04, I am building a PID controller model in Simulink and am trying to build and deploy it.
After roslaunching in a terminal which starts up all my other nodes (not built using Simulink), I'm trying to connect my Simulink node to my ROS device by using the IP addr outputted from ifconfig but am failing on this step.
It says that
Cannot connect to device. Check that the device address, username, and password are correct.
I have checked my address, username and password multiple times to ensure they are correct. Please see the photos below for details.
I have tried enabling SSH and disabling the firewall, to no avail.
photo.png
Thank you!

  댓글 수: 0

로그인 to comment.

태그

제품


릴리스

R2018b

답변 수: 1

Sebastian Castro 님의 답변 28 Mar 2019
 채택된 답변

Hi An,
Have you installed openssh-server on your Ubuntu machine? This is needed for the tests to succeed, far as I recall.
- Sebastian

  댓글 수: 1

Hi Sebastian,
It turns out the problem was with my machine. I did install openssh-server to enable SSH but it still did not work. I tried the whole process on another machine and it worked out fine. Thank you for looking into this :)

로그인 to comment.



Translated by