Matlab Beep at zooming in plot and evaluating variables

조회 수: 12(최근 30일)
Robbin van Hoek
Robbin van Hoek 2017년 8월 23일
답변: SK 2019년 10월 18일
I recently started noticing that, when clicking zooming buttons in a plot, matlab starts producing 'error' beeps. However, no error is printed to the command window, and also the zooming works without any problems.
I experience the same while in the variable editor and double clicking fields of a struct (to open them). This constant beeping is slowly driving me crazy and as of yet i have not been able to find what's causing it.
I already found: How to disable beep
but that turns it off if a delimiter is incorrect during coding, which is not when I hear the beeps.
Can anyone tell me what is causing these beeps and perhaps even better, how to turn them off?
  댓글 수: 2
Robbin van Hoek
Robbin van Hoek 2017년 8월 28일
well, the problem is that i cannot reproduce it at will (i realise this is not very usefull, im sorry). But to answer your question, I create a standard figure with (2D) subplots containing several line plots. The error beep then occurs sometimes when using the default 'Zoom In' and 'Zoom Out' buttons from the figure window.
I suspect it is maybe related to some memory issue due to the error i get in the 'getArrayEditorBrushCache.m' file (see comment on your answer bellow). I do always get the 'zooming error' beep in parallel to the 'data explore' error beep.

댓글을 달려면 로그인하십시오.

답변(6개)

Ahmet Karakucuk
Ahmet Karakucuk 2018년 3월 4일
편집: Ahmet Karakucuk 2018년 3월 4일
And unsolved.
getArrayEditorBrushCache.m is the source of error. It tries to "shade" entire row in the editor, but error pops up. Right now, commenting the following lines in the said m file seem to be an option (to get rid of the error). You can do so if you also don't have time to fix the problem.
If you don't have an array in a struct, then you may not see this error.
% % If any cell is brushed, the entire row must be shaded % if ~isvector(I) % I = repmat(any(I,2),[1 size(I,2)]); % end % if ~isempty(subsstr) % eval(['I = I' subsstr ';']); % end
file address: MATLAB\R2017b\toolbox\matlab\datamanager\+datamanager\getArrayEditorBrushCache.m
  댓글 수: 3
Stephen Hain
Stephen Hain 2018년 3월 29일
The lines to comment out appear to be 39-44. I get this same error, it is quite annoying.

댓글을 달려면 로그인하십시오.


Robin H
Robin H 2018년 5월 2일
편집: Robin H 2018년 5월 2일
I also receive this error. I have a structure with substructures:
A.B(n).C with C being a [1 x n] double.
When trying to open C via the workspace and "dbstop if error" is enabled Matlab R2018a stops at line 43 in
getArrayEditorBrushCache.m
43 eval(['I = I' subsstr ';']);
Quit Debugging or Continue repeats the error:
43 eval(['I = I' subsstr ';']);
43 eval(['I = I' subsstr ';']);
43 eval(['I = I' subsstr ';']);
43 eval(['I = I' subsstr ';']);
43 eval(['I = I' subsstr ';']);
43 eval(['I = I' subsstr ';']);
I'm not able to look at C at all due to the error.
This reminds me of a previous error I encountered where matlab stopped at the line "drawnow" in the print command. This was partially solved by adding a pause (0.02) command before every print.
Edit: A condition that may or may not contribute to this: - I use matlab via a NoMachine client on a central server

Bruce Lin
Bruce Lin 2017년 11월 16일
편집: Bruce Lin 2017년 11월 16일
I have this problem as well on R2017b under Windows.
Double-clicking variables to view them in the Variable window succeeds, but produces a beep as well.
Sometimes beeps occur when scrolling through a long list of rows in the Variable viewer (whether by using the mouse wheel, or pressing PageUp/PageDown on the keyboard)
It's tremendously annoying.

Jan
Jan 2017년 8월 23일
The term "recently" is a secure indicator, that you did change something (intentionally / unintentionally / without being aware). As soon as you found out when this has happened, there is a chance to find out what it was. Perhaps you have overwritten a builtin function (see https://www.mathworks.com/matlabcentral/fileexchange/27861-uniquefuncnames)?
Did you try to catch a silent error without output to the command window by
dbstop if all error
  댓글 수: 1
Robbin van Hoek
Robbin van Hoek 2017년 8월 23일
Thank you Jan for your very quick reply. I tried the
dbstop if all error
And tried reproducing the errors. For the problem in the editor the debugger jumps to the following file, in line 43.
C:\Program Files\MATLAB\R2016b\toolbox\matlab\datamanager\@datamanager\getArrayEditorBrushCache.m
For the problem in zooming in a plot, I cant reproduce the error as of now.
As of the unique function check. I get alot of identical function names, but most are related to matlab toolboxes (eg. rtwmakecfg, slblocks, getBlockHelpMapNameAndPath etc.), i scrolled through the rest of the results, but none of the function names that are returned ring a bell.

댓글을 달려면 로그인하십시오.


Stefano
Stefano 2019년 2월 19일
I suspect the error with the plots is linked to monitoring a variable as well.
Do you still have it is you close the "Variables" window/tab?

SK
SK 2019년 10월 18일
The problem persists in 2019a.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by