필터 지우기
필터 지우기

How can i change the Connectivity Configuration for arduino Target?

조회 수: 8 (최근 30일)
Karim Abdou
Karim Abdou 2017년 5월 25일
답변: Hassan Abouobaida 2021년 5월 11일
I downloaded TI C000 hardware support package and it worked fine for me. Now, I've downloaded Ardunino support package, and it works fine for just flashing my algorithms on Arduino. However, when I try to make PIL simulation I get this error message :
---------------------------------------------------------
Cannot perform a processor-in-the-loop (PIL) simulation for "gainer".
The configuration parameters for this model do not support the following connectivity configurations: Texas Instruments Code Composer Studio (IDE), Texas Instruments Code Composer Studio (TCP/IP), Texas Instruments Code Composer Studio (Serial)
To fix this error, update the configuration parameters or create a supported connectivity configuration. See Configure a SIL or PIL Simulation, Create a Connectivity Configuration for a Target, and Processor-in-the-Loop (PIL) Simulation in your product help.
----------------------------------------------------------
Any Texas Instruments text is hyperlinked, when I click it, it opens a configuration class with the following property. ConfigRegistry with properties:
ConfigName: 'Texas Instruments Code Composer Studio (IDE)'
ConfigClass: 'ticcsext.pil.ConnectivityConfig'
SystemTargetFile: {}
TemplateMakefile: {}
Toolchain: {}
TargetHWDeviceType: {}
So how can I change the property values of this class to be Arduino's configuration.
  댓글 수: 1
Martin Ross
Martin Ross 2017년 9월 15일
편집: Martin Ross 2017년 9월 18일
I am getting the same error message and have had no success in fixing it. Did you find a way to resolve it?
EDIT: I have now resolved my issue. It was due to the fact that I had 2 sl_customization.m files on the Matlab path, only 1 of which was necessary. This meant that the wrong target hardware device was being defined by my connectivity configuration and so it did not match the hardware device I had selected in the configuration parameters of my model.
This was a very frustrating error to try to solve, so I hope my explanation here helps other people who may have a similar problem.

댓글을 달려면 로그인하십시오.

답변 (1개)

Hassan Abouobaida
Hassan Abouobaida 2021년 5월 11일
Hello,
I get the same error, please help me.
................................................................................................................................
### Build procedure for model: 'Control' aborted due to an error.
Error using rtwbuild (line 301)
Cannot perform a processor-in-the-loop (PIL) simulation for "Control".
The configuration parameters for this model do not support the following
connectivity configurations: ALTERASOCSIM, XILINXZYNQSIM, Texas Instruments
C2000 Base, Texas Instruments Code Composer Studio (IDE), Texas Instruments Code
Composer Studio (TCP/IP), Texas Instruments Code Composer Studio (Serial)
To fix this error, update the configuration parameters or create a supported
connectivity configuration. See Configure a SIL or PIL Simulation, Create a
Connectivity Configuration for a Target, and Processor-in-the-Loop (PIL)
Simulation in your product help.

카테고리

Help CenterFile Exchange에서 Modeling에 대해 자세히 알아보기

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by