Need help troubleshooting error with Simulink Arduino tutorial related to time-response identification of RC circuit.

조회 수: 2(최근 30일)
Phil
Phil 2016년 12월 5일
댓글: Raghul 2017년 10월 3일
I'm working on control systems tutorials found here. I've gone through the majority of the tutorial without issue, however if I try to run the both blocks highlighted, I get a very strange error (attached). If I run either the orange highlighted block, or the blue highlight block by itself, I have no errors, and get the expected output. It's just both together that I'm having issues with.
Does anyone have experience with this? If so, how can I fix the problem?
  댓글 수: 1
Raghul
Raghul 2017년 10월 3일
Sir when i try to simulate the same tutorial in that website. I experienced this problem. Please suggest me to overcome this problem

댓글을 달려면 로그인하십시오.

채택된 답변

Hari Desanur
Hari Desanur 2016년 12월 12일
Try to build your Simulink model by using one of the following solvers instead of the default "ode3 (Bogacki-Shampine)" solver -
1. ode8 (Dormand-Prince RK8(7))
2. ode5 (Dormand-Prince)
3. ode2 (Heun)
4. ode1 (Euler)
This should fix the issue. You can change the solver by opening the Configuration Parameters (Ctrl+E) and then changing the 'Solver' under the 'Solver options' menu.
  댓글 수: 1
Phil
Phil 2016년 12월 21일
Thank you Hari, it worked for me using ode5 solver, I had issues using ode8 for some reason.

댓글을 달려면 로그인하십시오.

추가 답변(0개)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by