How can I resolve ELF file OS ABI invalid errors when starting license manager daemon on older OS?

조회 수: 53 (최근 30일)
I have an older Linux operating system hosting my license manager daemon. Upon startup, I receive several of the following error message: MLM: error while loading shared libraries: /mathworks/etc/glnxa64/../../sys/os/glnxa64/ ELF file OS ABI invalid
The MLM process eventually exists with a non-zero status: 88 14:48:29 (lmgrd) MLM exited with status 127 () 89 14:48:29 (lmgrd) Please correct problem and restart daemons
I am not able to update the OS on this system.
Is there a way I can move forward without changing the license server's OS?

답변 (1개)

Greg 2020년 4월 9일
Oddly, I received the same error (MLM exited with status 127 ()) mentioned above, but not the more useful "MLM: error ... file too short" message described and resolved in this question. The solution was the same (luckily, I had already solved this problem last week, but rebuilt my system and forgot to re-do it, so the original post mentioning sparked my memory).
For anyone else having this problem, go to the answer of the question I linked in the previous paragraph for full details. Or, find your license manager install folder, and create the symbolic link.
>> ln -sf
The numbers are likely not constant, so double check those. And the line above is meant to be run from the <flexlm>/sys/os/glnxa64/ directory.


Help CenterFile Exchange에서 Manage Products에 대해 자세히 알아보기

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by