How can I set the library dirctory for CCS cl2000?

조회 수: 6(최근 30일)
When I build my test model,it shows an error:
<Linking>
error: cannot find file "rts2800_fpu32.lib"
my lib direction is C:\ti\ccsv5\tools\compiler\c2000_6.1.3\lib, how can I set the search path for cl2000?
I tried to set the Arguments as "-i"C:/ti/ccsv5/tools/compiler/c2000_6.1.3/lib"" in the Linker tag of xmakefilesetup(), but the link command will become as :
"C:/ti/ccsv5/tools/compiler/c2000_6.1.3/bin/cl2000" -z -l"rts2800_fpu32.lib" -c -x -m"demo_model1.map"
-stack0x200 -o ./CustomMW/demo_model1.out -i"C:/ti/ccsv5/tools/compiler/c2000_6.1.3/lib"
that means the argumant '-l"rts2800_fpu32.lib"' is before '-i"C:/ti/ccsv5/tools/compiler/c2000_6.1.3/lib", I think that's why the error happend.
But how can I set the library directory befor the argumant '-l"rts2800_fpu32.lib"' ? This argument is added by matlab automatically :(
Anyone can help me?
Thanks.
'

채택된 답변

shiming liu
shiming liu 2016년 3월 25일
I still don't know why this problem happened, but I solved it :)
My model is test1.slx,so the Embeded Coder will build the directory C:\Users\Liu\Documents\MATLAB\test1_ticcs to save the generated C and other files.
I copied "rts2800_fpu32.lib" to the directory,and the Embeded Coder will generated test1.out correctly! (I still fighting for the problems in the next steps)
To make this action automatically, I set a Pre-build in the xmakefilesetup() windows,which is:
Pre-build tool: C:\Windows\System32\xcopy
Arguments: C:\ti\ccsv5\tools\compiler\c2000_6.1.3\lib\rts2800_fpu32.lib . /Y
The reason why use xcopy instead of copy: "copy" is not a Windows Command File, MATLAB can't call it.

추가 답변(0개)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by