MATLAB Answers

0

Errors when installing the iOS hardware support package in Matlab R2015a

salty 님이 질문을 제출함. 3 Jun 2015
최근 활동 sherif salem 님이 답변함. 22 Mar 2019
I am trying to install the iOS hardware support package in Matlab R2015a and to the part "Verifying Configuration of Your iOS Device" and I get the following errors:
Error using fprintf
Invalid format.
Error in realtime.setup.iOSFirmwareUpdate/createBuildDiagnostic (line 431)
Error in realtime.setup.iOSFirmwareUpdate/BuildApp (line 533)
Error in realtime.setup.iOSFirmwareUpdate/buildAndInstallTestApp (line 692)
Error in realtime.setup.iOSFirmwareUpdate.BuildDelayedCallback (line 797)
The test application that checks the provisioning profile builds and runs on the iPhone. Any ideas what I am doing wrong?

  댓글 수: 0

로그인 to comment.

태그

답변 수: 5

Jack Hider 님의 답변 6 Oct 2015

I have the same issue, has anyone got an answer

  댓글 수: 0

로그인 to comment.


saras 님의 답변 3 Nov 2015

Is the device provisioned? Also, what version of Xcode and iOS version are you using?

  댓글 수: 2

Yes the device is provisioned. I cannot remember what versions I was using when I got those errors. As I have updated to Xcode 7.1 and iOS 9.1, I am no longer running supported versions for the Simulink add-on. However when I tried again I get a different error. I can build the application and download it to the iPhone from Xcode, however when I go the next screen in the support package setup the window get a green tick by Building App, but the Running App phase get an error of "Unexpected failure (Error code: DOWNAPPNOUPD). Press 'Retry'.". Needless to say retry gives the same error.
I suspect this may be an incompatibility with our deployment tool and the version of iOS running on your device.
Just to clarify, does the app get deployed to the device at all, and just not launched? To put it simply, if you look on your device do you see the TestApp was deployed to your device?

로그인 to comment.


Tingting 님의 답변 11 Apr 2016

I also have the same problem with my iPad 4 iOS 9.3.1 on matlab r2015b

  댓글 수: 0

로그인 to comment.



So still no answer here huh... I think its because my phone is too updated. When I put the first test app on I have to add a bunch of new features to the program. Things like retina display support!! ugh.. Mathwork's focuses too much on Microsoft. Help us out here!!

  댓글 수: 0

로그인 to comment.


sherif salem 님의 답변 22 Mar 2019

I am running in the same issue but i am stuck in the build app phase. I dont make it to the run app phase. Please help me.

  댓글 수: 0

로그인 to comment.



Translated by