Problem At Sistem On Chip (SOC,PIL) Example Application

조회 수: 4 (최근 30일)
Burak Caykenari
Burak Caykenari . 2021년 12월 15일
댓글: Burak Caykenari . 2021년 12월 17일
Hello Everyone,
I have tried SoC (system on chip) basic 'closed loop control system' application using TI Delfino F28379D Launchpad
via MATLAB 2021b version. (
All instructions (end of document , 1-6) were applied step by step. At the end of load and run provess, I didn't encounter any important errors on the Soc Builder and matlab command window like a following figures.Only warnings were observed. I think these warnings do not affect working principle of the system too much.
Mainly, I did not see the expected Sampled ADC Value results.
Expected Waveform
Actual(measured) Waveform
As you can see, In Actual (measured) Sampled ADC value(red) differs from expected ADC value. ADC measurement isn't observed.
What is the main problem ? Can you explain ? Manythanks for your helps.

채택된 답변

Joel Van Sickel
Joel Van Sickel 2021년 12월 15일
If the software recommendations made by above commenters don't work, consider a hardware/connection issue.
Can you send a photo of the hardware setup you used to create the RC circuit? The fact that you are seeing a step response and reference go high, but no ADC results would indiciate a possible lack of connection. Either the RC circuit could be built incorrectly or the ADC sense was not connected tot he correct spot of the circuit. Do you have access to an oscilloscope to determine that the PWM signal is being generated as expected and connected to the RC circuit as expected?
  댓글 수: 1
Burak Caykenari
Burak Caykenari 2021년 12월 17일
Sorry for late response. Thank you. Problem is solved.

댓글을 달려면 로그인하십시오.

추가 답변 (3개)

Arun Munuswamy Sambandham
Arun Munuswamy Sambandham 2021년 12월 15일
편집: Arun Munuswamy Sambandham 님. 2021년 12월 15일
Hi Burak
I am assuming you are trying External Mode, in that case you had to connect the actual HW connection with F28379D launchpad (HW driving analog values to ADC pin of F28379D).
For PIL workflow the recommended steps are captured here And you need to setup your models differently and use SIL/PIL Manager app. Parent page for SoC Blockset C2000 PIL simulation can be found here
  댓글 수: 1
Burak Caykenari
Burak Caykenari 2021년 12월 17일
I will try example application using SIL/PIL app. This exacty what i want to do.

댓글을 달려면 로그인하십시오.

Dr Narayanaswamy P R Iyer
Dr Narayanaswamy P R Iyer 2021년 12월 15일
Check your PC RAM memory with that specified by MATHWORKS for the MATLAB version used.
  댓글 수: 1
Burak Caykenari
Burak Caykenari 2021년 12월 15일
Hi Sir,
Thank you for answering.
Do you think it is due to not enough PC RAM? Did I get it wrong?
How Can I control and fix it ? Can you explain briefly , if it is possible.

댓글을 달려면 로그인하십시오.

Dr Narayanaswamy P R Iyer
Dr Narayanaswamy P R Iyer 2021년 12월 15일
Most probably it could be due to insufficient RAM memory. Please check your PC RAM with the version of MATLAB specific requirement.


더 많은 답변 보기:  Power Electronics Community




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by