STM32F767ZI Simulink - "The target configuration uses time from a local timer, which is not based on simulation time"

조회 수: 11 (최근 30일)
Hi and good day,
I have a problem displaying the display/scope after run/deploy to the targeted hardware (STM32F767ZI). The simulink run perfectly (digital output, pwm, etc), but cannot display any value on the display/scope. Are there any suggestions that can solve this problem? Thank you.
PS: Simulink Coder Support Package Using STMicroelectronics Nucleo Boards

답변 (2개)

Venkatesh Chilapur
Venkatesh Chilapur 2021년 10월 26일
편집: Venkatesh Chilapur 2021년 10월 26일
This is a known limitation. If you use HW timer for getting the timestamps, you can't use Scope/Display to visualize signals.
Scopes/Displays only work with Simulation timestamps only.
Only SDI(Simulink Data Inspector) Dashboard Scope/Dashboard Displays can be used for visualization when HW timer for getting the timestamps is enabled.
You can enable/disable the "HW timer for getting the timestamps" here:
check box available in 'Configuration parameters > Hardware Implementation > External mode > Use actual timer to log realtime stamps' - with this option enabled, Scope, display, from workspace, to workspace blocks will not work as already noted above.
Venkatesh C

Lukas Pohl
Lukas Pohl 2023년 7월 19일
I have a followup question regarding the same issue:
Demonstration model stm32_external_mode uses both Dashboard Scope and regular Scope. With the default configuration I just need to press the Scopes Run button again right after the Monitor & Tune was run to display the data. Which is not supposed to work based on provided information. I tried to reproduce this behavior in my model, Dashboard Scope works, but the regular Scope is not (it worked in demo). Is the behaviour of regular Scope in the demo something that is not supposed to work and I should not be attempting to "make it work"?

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by