Main Content

이 번역 페이지는 최신 내용을 담고 있지 않습니다. 최신 내용을 영문으로 보려면 여기를 클릭하십시오.

영상 뷰어 앱에서 픽셀 정보 가져오기

영상 뷰어 앱은 개별 픽셀이나 픽셀 그룹의 픽셀 값과 좌표를 표시하는 툴을 제공합니다. 픽셀의 위치 및 값 정보를 저장할 수 있습니다.

영상 뷰어에서 개별 픽셀 값 확인하기

영상 뷰어는 영상의 개별 픽셀에 대한 위치와 값 정보를 툴의 왼쪽 아래 코너에 표시합니다. 픽셀의 값 및 위치 정보는 포인터가 현재 놓인 위치의 픽셀을 나타냅니다. 영상 뷰어는 영상 위에서 포인터를 이동하면 이 정보를 업데이트합니다.

픽셀 정보의 형식은 영상 유형에 따라 달라집니다.

영상 유형

픽셀 정보

명암

(X,Y) 명암

(13,30) 82

인덱스

(X,Y) <인덱스> [R G B]

(2,6) <4> [0.29 0.05 0.32]

이진

(X,Y) BW

(12,1) 0

트루컬러

(X,Y) [R G B]

(19,10) [15 255 10]

CDataMapping 속성이 direct로 설정된 부동소수점 영상

(X,Y) 값 <인덱스> [R G B]

(19,10) 82 <4> [15 255 10]

다음 그림은 영상 뷰어의 픽셀 정보 툴에 픽셀의 위치와 회색조 픽셀 값이 표시된 모습을 보여줍니다.

참고

impixelinfo 함수를 사용하여 imshow로 표시한 Figure에서 픽셀 값 정보를 얻을 수도 있습니다.

표시된 픽셀 위치 및 값 정보를 저장하려면 영상에서 픽셀을 마우스 오른쪽 버튼으로 클릭하고 픽셀 정보 복사 옵션을 선택하십시오. 영상 뷰어가 클립보드에 x, y 좌표와 픽셀 값을 복사합니다. 마우스 오른쪽 버튼을 클릭하고 상황별 메뉴에서 붙여넣기를 선택하면 이 픽셀 정보를 MATLAB® 작업 공간이나 다른 응용 프로그램에 붙여 넣을 수 있습니다.

영상 영역의 픽셀 값 확인하기

영상 뷰어에 표시된 영상의 특정 영역의 픽셀 값을 보려면 픽셀 영역 툴을 사용하십시오. 픽셀 영역 툴은 픽셀 영역 사각형이라 불리는 사각형을 영상 뷰어에 표시된 영상 위에 겹쳐 놓습니다. 이 사각형은 픽셀 영역 툴 창에 최대한 클로즈업하여 표시할 픽셀 그룹을 정의합니다.

다음 그림은 영상 뷰어에 픽셀 영역 툴이 표시된 모습을 보여줍니다. 픽셀 영역 툴에 자체 픽셀 정보 툴이 표시되어 있는 것을 볼 수 있습니다.

이어지는 섹션에서는 픽셀 영역 툴 사용에 대한 자세한 내용을 제공합니다.

참고

Figure에서 impixelregion 함수를 사용하여 픽셀 영역 정보를 얻을 수도 있습니다(예: imshow를 사용하여 표시한 Figure).

영역 선택하기

픽셀 영역 툴을 시작하려면 영상 뷰어 도구 모음에서 픽셀 영역 버튼 을 클릭하거나 메뉴에서 픽셀 영역 옵션을 선택하십시오. 영상 뷰어가 대상 영상의 중앙에 픽셀 영역 사각형 을 표시하고 픽셀 영역 툴을 엽니다.

참고

영상을 스크롤하면 픽셀 영역 사각형이 현재 표시된 영상 부분 밖으로 이동할 수 있습니다. 픽셀 영역 사각형을 현재 표시된 영상 부분의 중앙으로 다시 가져오려면 픽셀 영역 버튼을 다시 클릭하십시오. 큰 영상에서 픽셀 영역 툴을 찾는 데 도움이 필요하면 픽셀 영역 사각형의 위치 확인하기 항목을 참조하십시오.

마우스를 사용하여 픽셀 영역 사각형 위로 포인터를 가져갑니다. 포인터가 십자형 화살표 로 바뀝니다.

마우스 왼쪽 버튼을 클릭하고 픽셀 영역 사각형을 영상의 임의 부분으로 끌어서 놓습니다. 영상 위에서 픽셀 영역 사각형을 이동하면 픽셀 영역 툴이 픽셀 값을 업데이트하여 표시합니다. 픽셀 영역 툴 창의 스크롤 막대를 이동하여 픽셀 영역 사각형을 이동할 수도 있습니다.

보기 사용자 지정하기

영상 픽셀을 더욱 확대하여 보려면 픽셀 영역 툴 도구 모음의 확대/축소 버튼을 사용하십시오. 확대하면 픽셀 영역 툴에 표시되는 픽셀의 크기가 커지고 보다 적은 수의 픽셀이 표시됩니다. 축소하면 픽셀 영역 툴에 표시되는 픽셀의 크기가 작아지고 보다 많은 수의 픽셀이 표시됩니다. 배율을 변경하지 않은 채로 툴에 표시되는 픽셀의 개수를 변경하려면 마우스를 사용하여 픽셀 영역 툴의 크기를 조정하십시오.

확대하거나 축소하면 픽셀 영역 사각형의 크기가 배율에 따라 변경되는 것을 볼 수 있습니다. 마우스를 사용하여 픽셀 영역 사각형의 크기를 조정할 수 있습니다. 픽셀 영역 사각형의 크기를 조정하면 픽셀 영역 툴에 표시되는 픽셀의 배율이 변경됩니다.

지원되는 정도의 배율인 경우, 픽셀 영역 툴이 각 픽셀 위에 숫자형 값을 겹쳐 표시합니다. RGB 영상의 경우에는 영상의 각 대역에 해당하는 3개의 숫자형 값이 정보에 포함됩니다. 인덱스 영상의 경우에는 인덱스 값과 해당 RGB 값이 정보에 포함됩니다. 숫자형 값을 표시하지 않으려면 픽셀 영역 툴의 편집 메뉴로 이동하여 픽셀 값 겹쳐 놓기 옵션을 선택 취소하십시오.

픽셀 영역 사각형의 위치 확인하기

대상 영상에서 픽셀 영역의 현재 위치를 확인하려면 툴 하단에 주어지는 픽셀 정보를 사용할 수 있습니다. 이 정보는 대상 영상의 좌표계에서의 픽셀의 x, y 좌표를 나타냅니다. 픽셀 영역 사각형을 대상 영상 위에서 이동하더라도 툴 하단에 주어지는 픽셀 정보는 커서를 다시 픽셀 영역 툴 위에 올려놓기 전까지 업데이트되지 않습니다.

픽셀 영역 툴의 편집 메뉴에서 위치 복사 옵션을 선택하여 픽셀 영역의 현재 위치를 가져올 수도 있습니다. 이 옵션은 위치 정보를 클립보드에 복사합니다. 위치 정보는 [xmin ymin width height] 형식의 벡터입니다. 이 위치 벡터를 MATLAB 작업 공간이나 다른 응용 프로그램에 붙여 넣으려면 마우스 오른쪽 버튼을 클릭하고 상황별 메뉴에서 붙여넣기를 선택하십시오.

다음 그림은 픽셀 영역 툴의 이러한 구성요소를 보여줍니다.

픽셀 영역 툴의 영상 보기 출력하기

픽셀 영역 툴에 표시되는 영상의 보기를 출력할 수 있습니다. 픽셀 영역 툴의 파일 메뉴에서 Figure에 출력 옵션을 선택합니다. 자세한 내용은 Print Images 항목을 참조하십시오.

영상 뷰어의 영상 표시 범위 확인하기

영상 뷰어는 회색조 영상의 픽셀 표시 범위에 대한 정보를 제공합니다. 표시 범위는 좌표축 CLim 속성의 값으로, Figure 컬러맵에 대한 영상 CData의 매핑을 제어합니다. CLim은 요소를 2개 가진 벡터 [cmin cmax]로, 컬러맵의 첫 번째 색에 매핑할 CData 값(cmin)과 컬러맵의 마지막 색에 매핑할 CData 값(cmax)을 지정합니다. 그 사이의 데이터 값은 선형적으로 스케일링됩니다.

회색조 영상의 경우, 영상 뷰어는 이 정보를 창 오른쪽 아래 코너의 표시 범위 툴에 표시합니다. 영상 뷰어는 인덱스, 트루컬러 또는 이진 영상에 대해 표시 범위 툴을 표시하지 않습니다.

다음 그림은 영상 뷰어에 영상이 표시 범위 정보와 함께 표시된 모습을 보여줍니다.

참고

Figure에서 imdisplayrange 함수를 사용하여 영상 표시 범위를 얻을 수도 있습니다(예: imshow를 사용하여 표시한 Figure).

표시 범위를 조정하여 영상의 대비와 밝기를 변경할 수 있습니다. 자세한 내용은 Adjust Image Contrast in Image Viewer App 항목을 참조하십시오.

참고 항목

| | | |

관련 항목