ruleview

Open Rule Viewer

Syntax

ruleview(fis)
ruleview(fileName)

Description

ruleview(fis) opens the Rule Viewer for the fuzzy inference system, fis. Specify fis as a mamfis or sugfis object. The Rule Viewer is used to view the entire implication process from beginning to end. You can move around the line indices that correspond to the inputs and then watch the system readjust and compute the new output. Refer to The Rule Viewer for more information about how to use ruleview.

ruleview(fileName) depicts the fuzzy inference diagram for the fuzzy inference system stored in file fileName. Specify fileName as a character vector or string with or without the .fis extension.

Menu Items

In the Rule Viewer, there is a menu bar that allows you to open related UI tools, open and save systems, and so on. The File menu for the Rule Viewer is the same as the one found in the Fuzzy Logic Designer.

  • Use the Edit menu items:

    Undo to undo the most recent action

    FIS properties to open the Fuzzy Logic Designer

    Membership functions to invoke the Membership Function Editor

    Rules to invoke the Rule Editor

  • Use the View menu item:

    Surface to invoke the Surface Viewer

  • Use the Options menu item:

    Format to set the format in which the rule appears: Verbose, Symbolic, or Indexed.

If you click on the rule numbers on the left side of the fuzzy inference diagram, the rule associated with that number appears in the status bar at the bottom of the Rule Viewer.

Compatibility Considerations

expand all

Not recommended starting in R2018b

Introduced before R2006a