MATLAB Answers

CRL:"Simulation Target IPP BLAS" cannot be found in the registry

조회 수: 71(최근 30일)
Andy
Andy 2013년 8월 4일
답변: Bill Tubbs 2021년 6월 2일
Running Simulink with an accelerator gives me this error on my desktop computer. It compiles fine under normal, accelerator and rapid on my laptop, but does not do the accelerator on my desktop. Sometimes, it won't even run under normal. I have uninstalled and reinstalled MATLAB, C compilers and I even formatted the hard drive and reinstalled the operating system thinking it maybe some corrupt file and the error is still here. I have searched the Internet and I could not find anything.
I have a presentation I need to make in a day using my desktop so I would appreciate any help.
  댓글 수: 1
Bill Tubbs
Bill Tubbs 2021년 6월 2일
I have this same error on Mac OS X now. Various models that were working 2 days ago are now raising this.
Is there any further information or solutions?

댓글을 달려면 로그인하십시오.

채택된 답변

Will Forfang
Will Forfang 2013년 8월 4일
Do you have Avast Anti-virus, by chance? As of this morning, I began receiving the same error that you mentioned in your title.
After some inspection, I found that Avast had quarantined this file:
C:\Program Files\MATLAB\R2013a\bin\win64\physmod_gui_core_fkw.dll
Restoring the file from quarantine and disabling Avast resolved the issue for me.
  댓글 수: 2
Joshua Dillon
Joshua Dillon 2017년 12월 26일
I also experienced this problem with a recent Windows 10 update. The only solution I found was to uninstall/reinstall MATLAB. Not ideal but it seems to be working.

댓글을 달려면 로그인하십시오.

추가 답변(3개)

Andy
Andy 2013년 8월 5일
Thank you, that worked. I can't believe I ended up reformatting my system for this....stupid avast must have made a definition update overnight.


Bill Tubbs
Bill Tubbs 2021년 6월 2일
Problem was solved for me on Mac OS X by closing MATLAB and all Simulink files and restarting.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by