Error when running programme on external Android

조회 수: 4(최근 30일)
Hello all
I have encountered this error repeatedly, without being able to find a solution at all.
The test app by MATLAB Connector works perfectly fine.
The applications i create are able to run when uploaded using "deploy to hardware"
However, when the play button is pressed, the following error is obtained, as a result, i cannot read my android's sensor data in my MATLAB PC.
""
Error occurred while executing External Mode MEX-file 'ext_comm': Failed to connect to the target. Possible reasons for the failure: a) The target is not switched on. b) The target is not connected to your host machine. c) The application for the model is not running on the target. You might have clicked the Stop button. If the Run button is not dimmed, click it. Otherwise, click the Build button, which downloads and runs your application on the target. Caused by: An error occurred attempting to open an rtIOStream. More detail may be reported in the MATLAB command window
""
Any help is greatly appreciated.
Thank you !

채택된 답변

Kiat Nern Yeo
Kiat Nern Yeo 2019년 6월 10일
Hi Sir
Yes i have used both the simulink display block, and the android data display, and have also set the mode to external and run time to inf.
Both these signals are coming out from the same android sensor block.
Best regards
  댓글 수: 5
Kiat Nern Yeo
Kiat Nern Yeo 2019년 6월 11일
Ok got it. Will call them. Thank you very much !

댓글을 달려면 로그인하십시오.

추가 답변(2개)

Sruthi Yenugula
Sruthi Yenugula 2019년 6월 7일
Hi,
Use this link to run the external mode
Make sure your device and pc are connected to same wifi network when running external mode.
  댓글 수: 1
Kiat Nern Yeo
Kiat Nern Yeo 2019년 6월 19일
Yup i got it. The solution is to make sure that both devices are connected to the same private and secured network !

댓글을 달려면 로그인하십시오.


Kiat Nern Yeo
Kiat Nern Yeo 2019년 6월 9일
Hi Sir. Thank you for replying
I have went through the example and the app can indeed be deployed onto my phone, and the sensor values can be read within my phone's screen.
However, it still does not show up in simulink's scope or display blocks.
I have also performed androidhwsetup, and the test app can run.
The USB cable is also always attached, and both the phone and computer are connected to the same private network.
I also have the proper android driver installed, along with the required android studio SDK and NDK.
Is there something that i could have missed ?
Best regards sir.
  댓글 수: 2
Kiat Nern Yeo
Kiat Nern Yeo 2019년 6월 19일
Yup i got it. The solution is to make sure that both devices are connected to the same private and secured network !

댓글을 달려면 로그인하십시오.

범주

Find more on Simulink Support Package for Android Devices in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by