"Not enough input arguments" in Matlab Applications

조회 수: 3(최근 30일)
Nicolas Kruse
Nicolas Kruse 2022년 12월 1일
댓글: Jenson 2023년 1월 31일
In both the 'property inspector' and 'app designer' I run into similar issues, namely a "not enough input arguments" error when trying to utilise any of the ui elements in said applications.
The image below is the result of simply
  1. calling imagesc, or any other plotting function, with arbitrary data
  2. opening the property inspector
  3. trying to alter an arbitrary property. In this case I tried to change the font from Helvetica to something else, but it happens with any change.
In the app designer, a similar problem appears. The image below is the result of following the official getting started video from Mathworks
  1. opening a new blank app
  2. trying to drag & drop a component into the 'design view'
These errors occur both on my work PC and my home laptop, both on the same license but with no other marked similarity.
I'm curious if anyone has run into similar problems and knows a solution. Thank you.


Gokul Nath S J
Gokul Nath S J 2022년 12월 6일
Hi Nicolas Kruse,
I assume you are using MATLAB in windows operating system, both in your office and at home. I suggest you to try the following workaround.
Kindly open MATLAB with the administrator credentials and try replicating all the steps that you mentioned above.
Also, please refer to the following link related to app designer.
  댓글 수: 4
Jenson 2023년 1월 31일
Hi Gokul,
I have the identical issue with Nicolas has. Is there's a solution yet? It seems only happens on my laptop. Unfortunately it's a company laptop, i can't run it with Admin due to IT rule. However, my colleagues don't see the same issue.

댓글을 달려면 로그인하십시오.


Find more on Introduction to Installation and Licensing in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by