Data Store Read/Write block 'IndexMode' parameter setting error

조회 수: 1(최근 30일)
Hi.
I want to use 'Data Store Memory/Rea/Write' blocks with Indexing option.
However, when I tried to enable indexing and set the IndexMode parameters, an error occurs like a screenshot.
Is this a problem with a specific MATLAB version?
I'm using the MATLAB/Simulink ver.2021b on the Windows 10.

답변(1개)

Mark McBroom
Mark McBroom 2022년 9월 11일
It sounds like the Data Store Memory set up to be scalar. Open the Data Store Memory block for Data Store A and set the deminsion to be > 1
  댓글 수: 1
진석 정
진석 정 2022년 9월 13일
Thank you for your answer.
However, the same problem occurs even though the dimension of the Data Store Memory is set to be greater than 1.
MATLAB 2021b for Linux worked fine.
In my opinion, this seems a bug on the version for Windows or Korean.

댓글을 달려면 로그인하십시오.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by