Cannot run xPC tartget

조회 수: 3 (최근 30일)
Anh
Anh 2013년 11월 18일
답변: Anh 2013년 11월 22일
Hi everybody, I am testing Mathworks xPC Target on an embedded PC. I tried with both RS232 and TCP/IP communication. Everytime, the xPC Loader ran and display the following image without any error.
When I ran xpctest from the host computer, it said I had either RS232 connection problem (in case of using RS232), or cannot ping the target (with TCP/IP).
This is urgent, any help or suggestion are highly appreciated.
  댓글 수: 1
Anh
Anh 2013년 11월 18일
I checked the RS232 or Ethernet cable and everything looked fine.

댓글을 달려면 로그인하십시오.

채택된 답변

Gordon Weast
Gordon Weast 2013년 11월 22일
Anh,
We've had some trouble with the graphics in some PCs when used as a target machine. This looks like your machine might be one of those.
You didn't say which version of Matlab you're using. You didn't say what make this target machine is.
This kind of problem is one of the strong reasons we have partnered with SpeedGoat to put together machines that we know work. There are just too many 'other' machines to have any confidence that all machines work.
Please contact MathWorks tech support about this issue, but the answer may be that you'll only be able to use this machine in text mode with graphics disabled.
Gordon Weast xPC Target Development MathWorks

추가 답변 (1개)

Anh
Anh 2013년 11월 22일
Thank you Gordon for your response. Here are some more information about the target PC that we are using: Aaeon, PFM-CVS single board computer with Atom N2600 cpu. I realized that in the BIOS settings of that target PC, properties such as Plu and Play, or Power Saving are not available. Such properties have to be disabled as guided by the xPC user guide. It will be useful if we have a list of what machine or cpu will or will not work.

카테고리

Help CenterFile Exchange에서 Development Computer Setup에 대해 자세히 알아보기

태그

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by