이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

라이브 스크립트에서 Figure 수정하기

라이브 편집기에서 Figure를 대화형 방식으로 수정할 수 있습니다. 제공된 툴을 사용하여 데이터를 탐색하고 Figure에 서식, 주석 또는 추가 좌표축을 추가합니다. 그런 다음, 생성된 코드를 사용하여 변경 사항을 반영하도록 코드를 업데이트합니다.

데이터 탐색하기

Figure 위에 마우스 포인터를 올려놓으면 Figure 좌표축의 오른쪽 상단 코너에 표시되는 툴을 사용하여 스크립트에서 Figure를 패닝, 확대/축소, 회전할 수 있습니다.

  • — 데이터 값을 표시할 수 있는 데이터팁을 추가합니다.

  • — 플롯을 회전합니다(3차원 플롯만 해당).

  • — 플롯을 패닝합니다.

  • , — 플롯을 확대하거나 축소합니다.

  • — 모든 패닝, 확대/축소, 회전 동작을 실행 취소하고 플롯의 원래 보기로 복원합니다.

동작을 실행 취소하거나 다시 실행하려면 툴스트립의 오른쪽 위 코너에 있는 또는 을 클릭하십시오.

참고

  • 저장된 라이브 스크립트를 열면 각 출력 Figure 옆에 가 표시되어 대화형 방식 툴을 아직 사용할 수 없음을 나타냅니다. 이러한 툴을 사용하려면 라이브 스크립트를 실행하십시오.

  • 대화형 방식 툴은 보이지 않는 좌표축에서는 사용할 수 없습니다.

100명의 환자에 대한 건강 정보를 살펴본다고 가정하겠습니다. patients.mlx라는 라이브 스크립트를 만든 후, 데이터를 불러오고 여성 환자와 남성 환자로 구성된 두 개 환자 그룹의 키와 체중을 보여주는 산점도 플롯을 추가하는 코드를 추가합니다. 라이브 편집기(Live Editor) 탭으로 이동한 후 실행(Evaluate)을 클릭하여 코드를 실행합니다.

load patients

figure
Gender = categorical(Gender);
scatter(Height(Gender=='Female'),Weight(Gender=='Female'));
hold on
scatter(Height(Gender=='Male'),Weight(Gender=='Male'));
hold off

환자의 키가 64인치인 점을 탐색합니다(1인치 = 2.54cm). 버튼을 선택하고 키가 64인 데이터 점 중 하나를 클릭합니다. MATLAB®에서 Figure가 확대됩니다.

Figure 변경 내용으로 코드 업데이트하기

라이브 스크립트에서 출력 Figure를 수정할 때 Figure의 변경 내용이 스크립트에 자동으로 추가되지 않습니다. 각 상호 작용마다 MATLAB은 상호 작용을 재현하는 데 필요한 코드를 생성하고 Figure 아래나 오른쪽에 이 코드를 표시합니다. 코드 업데이트(Update Code) 버튼을 사용하여 생성된 코드를 스크립트에 추가합니다. 그러면 다음에 라이브 스크립트를 실행할 때 상호 작용이 재현됩니다.

예를 들어, 라이브 스크립트 patients.mlx에서 키가 64인 환자를 확대한 후 코드 업데이트(Update Code) 버튼을 클릭합니다. MATLAB은 생성된 코드를 플롯 생성을 위한 코드가 포함된 라인 뒤에 추가합니다.

xlim([61.31 69.31])
ylim([116.7 183.3])
MATLAB이 생성된 코드를 배치할 위치를 결정할 수 없는 경우 코드 업데이트(Update Code) 버튼이 비활성화됩니다. 예를 들면 스크립트를 다시 실행하지 않고 코드를 수정하는 경우에 해당합니다. 이 경우에는 복사(Copy) 버튼을 사용하여 생성된 코드를 클립보드에 복사합니다. 그러면 스크립트의 적절한 위치에 코드를 붙여 넣을 수 있습니다.

서식과 주석 추가하기

데이터 탐색 외에도, 제목, 레이블, 범례, 그리드 선, 화살표, 선을 추가하여 대화형 방식으로 Figure에 서식을 지정하고 주석을 달 수 있습니다. 항목을 추가하려면 먼저 원하는 Figure를 선택하십시오. 그런 다음, Figure 탭으로 이동하여 주석(Comment) 섹션에서 사용 가능한 옵션 중 하나를 선택합니다. 섹션 오른쪽에 있는 아래쪽 화살표를 사용하여 사용 가능한 모든 주석을 표시합니다. 서식 지정 또는 주석 옵션을 즐겨찾기에 추가하려면 원하는 주석 아이콘의 오른쪽 상단에 있는 별표를 클릭하십시오. 서식 지정 또는 주석 동작을 실행 취소하거나 다시 실행하려면 툴스트립의 오른쪽 위 코너에 있는 또는 을 클릭하십시오.

주석 옵션은 다음과 같습니다.

  • 제목(Title) — 좌표축에 제목을 추가합니다. 기존 제목을 수정하려면 기존 제목을 클릭하고 수정된 텍스트를 입력하십시오.

  • X 레이블(X-Label), Y 레이블(Y-Label) — 좌표축에 레이블을 추가합니다. 기존 레이블을 수정하려면 기존 레이블을 클릭하고 수정된 텍스트를 입력하십시오.

  • 범례(Legend) — Figure에 범례를 추가합니다. 기존 범례 설명을 수정하려면 기존 설명을 클릭하고 수정된 텍스트를 입력하십시오. 좌표축에서 범례를 제거하려면 주석(Comment) 섹션에서 범례 제거(Remove Legend)를 선택하십시오.

  • 컬러바(Colorbar) — Figure에 컬러바 범례를 추가합니다. 좌표축에서 컬러바 범례를 제거하려면 주석(Comment) 섹션에서 컬러바 제거(Remove Colorbar)를 선택하십시오.

  • 그리드(Grid), X 그리드(X-Grid), Y 그리드(Y-Grid) — Figure에 그리드 선을 추가합니다. 주석(Comment) 섹션에서 그리드 제거(Remove Grid)를 선택하여 좌표축에서 모든 그리드 선을 제거합니다.

  • 선(Lines), 화살표(Arrow), 텍스트 화살표(Text Arrow), 양방향 화살표(Double Arrow) — Figure에 선 주석 또는 화살표 주석을 추가합니다. 화살 꼬리부터 화살촉까지 화살표를 그립니다. 기존 주석을 이동하려면 해당 주석을 클릭하여 선택한 후 원하는 위치로 끌어 놓으십시오. 선택한 주석을 삭제하려면 Delete 키를 누르십시오.

참고

Figure 탭을 사용하여 서식과 주석을 추가하는 기능은 보이지 않는 좌표축에서는 지원되지 않습니다.

예를 들어, patients.mlx의 Figure에 서식과 주석을 추가한다고 가정하겠습니다.

  1. 제목 추가주석(Comment) 섹션에서 제목(Title)을 선택합니다. 텍스트 입력을 요청하는 파란색 사각형이 나타납니다. 텍스트 Weight vs. Height를 입력하고 Enter 키를 누릅니다.

  2. X 레이블과 Y 레이블 추가주석(Comment) 섹션에서 X 레이블(X-Label)을 선택합니다. 텍스트 입력을 요청하는 파란색 사각형이 나타납니다. 텍스트 Height를 입력하고 Enter 키를 누릅니다. Y 레이블(Y-Label)을 선택합니다. 텍스트 입력을 요청하는 파란색 사각형이 나타납니다. 텍스트 Weight를 입력하고 Enter 키를 누릅니다.

  3. 범례 추가주석(Comment) 섹션에서 범례(Legend)를 선택합니다. 좌표축의 오른쪽 위 코너에 범례가 나타납니다. 범례에서 data1 설명을 클릭하고 텍스트를 Female로 바꿉니다. 범례에서 data2 설명을 클릭하고 텍스트를 Male로 바꿉니다. Enter 키를 누릅니다.

  4. 그리드 선 추가주석(Comment) 섹션에서 그리드(Grid)를 선택합니다. 좌표축에 그리드 선이 나타납니다.

  5. 화살표 주석 추가주석(Comment) 섹션에서 텍스트 화살표(Text Arrow)를 선택합니다. 화살 꼬리부터 화살촉까지 화살표를 그리고, 산점도 플롯에서 체중이 가장 가벼운 환자를 가리키도록 화살표의 위치를 지정합니다. 텍스트 Lightest Patient를 입력하고 Enter 키를 누릅니다.

  6. 코드 업데이트(Update Code) — 선택한 Figure에서 코드 업데이트 버튼을 클릭합니다. 이제 라이브 스크립트에 Figure 변경 사항을 재현하는 데 필요한 코드가 포함됩니다.

    grid on
    legend({'Female','Male'})
    title('Weight vs Height')
    xlabel('Height')
    ylabel('Weight')
    annotation('textarrow',[0.455 0.3979],[0.3393 0.13],'String','Lightest Patient');
    

여러 서브플롯을 추가하고 수정하기

Figure에 서브플롯을 생성하여 여러 플롯을 결합할 수 있습니다. Figure에 여러 서브플롯을 추가하려면 서브플롯(Subplot) 버튼을 사용하여 Figure를 서브플롯으로 구성된 그리드로 분할하십시오. 먼저 원하는 Figure를 선택합니다. 그런 다음, Figure 탭으로 이동하고 서브플롯(Subplot) 버튼을 사용하여 서브플롯 레이아웃을 선택합니다. Figure에 서브플롯이 하나인 경우에는 서브플롯 추가만 가능합니다. Figure에 여러 개의 서브플롯이 있는 경우에는 서브플롯(Subplot) 버튼이 비활성화되어 있습니다.

예를 들어, 흡연 환자와 비흡연 환자의 혈압을 비교하려는 경우를 생각해 보겠습니다. patients_smoking.mlx라는 라이브 스크립트를 만들고 100명의 개별 환자에 대한 건강 정보를 불러오는 코드를 추가합니다.

load patients

라이브 편집기(Live Editor) 탭으로 이동한 후 실행(Evaluate)을 클릭하여 코드를 실행합니다.

흡연 환자의 수축기 혈압과 비흡연 환자의 수축기 혈압을 보여주는 산점도 플롯을 추가합니다. 코드를 실행합니다.

figure
scatter(Age(Smoker==1),Systolic(Smoker==1));
hold on
scatter(Age(Smoker==0),Systolic(Smoker==0));
hold off

Figure 탭에서 서브플롯(Subplot)을 선택하고 두 개 가로 그래프의 레이아웃을 선택합니다.

새로 생성된 Figure에서 코드 업데이트(Update Code) 버튼을 클릭합니다. 이제 라이브 스크립트에 두 서브플롯을 재현하는 데 필요한 코드가 포함됩니다.

subplot(2,1,1,gca)
subplot(2,1,2)

흡연 환자의 이완기 혈압과 비흡연 환자의 이완기 혈압을 보여주는 산점도 플롯을 추가합니다. 코드를 실행합니다.

scatter(Age(Smoker==1),Diastolic(Smoker==1));
hold on
scatter(Age(Smoker==0),Diastolic(Smoker==0));
hold off

다음과 같이 서식을 추가합니다.

  1. 각 서브플롯에 제목 추가주석(Comment) 섹션에서 제목(Title)을 선택합니다. 각 서브플롯에 텍스트 입력을 요청하는 파란색 사각형이 나타납니다. 첫 번째 서브플롯에 텍스트 Systolic Blood Pressure of Smokers vs Non-Smokers를 입력하고 두 번째 서브플롯에 텍스트 Diastolic Blood Pressure of Smokers vs Non-Smokers를 입력한 후 Enter 키를 누릅니다.

  2. 각 서브플롯에 그리드 선 추가주석(Comment) 섹션에서 그리드(Grid)를 선택합니다. 각 서브플롯에 그리드 추가(Add Grid) 아이콘이 나타납니다. 각 서브플롯에서 그리드 추가(Add Grid) 아이콘을 클릭합니다. 두 서브플롯에 모두 그리드 선이 나타납니다.

  3. 코드 업데이트(Update Code) — 선택한 Figure에서 코드 업데이트 버튼을 클릭합니다. 이제 라이브 스크립트에 Figure 변경 사항을 재현하는 데 필요한 코드가 포함됩니다.

    subplot(2,1,1)
    grid on
    title('Systolic Blood Pressure of Smokers vs Non-Smokers')
    subplot(2,1,2)
    grid on
    title('Diastolic Blood Pressure of Smokers vs Non-Smokers')

Figure를 저장하고 인쇄하기

Figure 수정 중에 언제든지 나중에 사용할 목적으로 Figure를 저장하거나 인쇄할 수 있습니다.

  1. 출력값의 오른쪽 위 코너에 있는 아이콘을 클릭합니다. 그러면 Figure가 별도의 Figure 창에 열립니다.

    1. Figure를 저장하려면 — 파일(File) > 다른 이름으로 저장(Save As)을 선택하십시오. Figure 저장에 대한 자세한 내용은 다른 응용 프로그램에서 열 수 있도록 Figure 저장하기 또는 나중에 MATLAB에서 다시 열 수 있도록 Figure 저장하기 항목을 참조하십시오.

    2. Figure를 인쇄하려면 — 파일(File) > 인쇄(Print)를 선택하십시오. Figure 인쇄에 대한 자세한 내용은 파일 메뉴에서 Figure 인쇄하기 항목을 참조하십시오.

참고

별도의 Figure 창에서 Figure에 대해 변경한 내용은 라이브 스크립트에 반영되지 않습니다. 마찬가지로, 라이브 스크립트에서 Figure에 대해 변경한 내용은 열려 있는 Figure 창에 반영되지 않습니다.

관련 항목