이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

파일과 폴더 비교하기 및 파일 병합하기

파일과 폴더 비교하기

비교 툴을 사용하여 선택한 파일 쌍이나 폴더 쌍 간의 차이점을 표시할 수 있습니다. 일부 파일 형식의 경우 한 파일의 변경 사항을 다른 파일에 병합할 수도 있습니다.

비교 프로세스는 다음과 같은 세 단계로 이루어집니다.

  1. 비교할 파일이나 폴더를 선택합니다.

  2. 비교 유형을 선택합니다.

  3. 비교 리포트를 탐색합니다.

비교할 파일이나 폴더 선택하기

비교할 파일이나 폴더를 선택할 때 사용할 수 있는 방법은 다음과 같습니다.

  • 현재 폴더 브라우저 — 하나의 파일이나 폴더를 선택하고 마우스 오른쪽 버튼을 클릭한 다음 비교 대상(Compare Against)을 선택합니다. 비교할 두 번째 항목을 찾아서 선택하거나 파일 브라우저에서 파일이나 폴더를 끌어서 놓습니다.

    두 파일이나 하위 폴더를 선택하고 마우스 오른쪽 버튼을 클릭한 후 선택한 파일/폴더 비교(Compare Selected Files/Folders)를 선택할 수도 있습니다.

  • 편집기 또는 라이브 편집기편집기(Editor) 또는 라이브 편집기(Live Editor) 탭으로 이동한 후 파일(File) 섹션에서 비교(Compare)를 클릭합니다. 비교 툴이 현재 열려 있는 파일과 비교할 첫 번째 파일을 자동으로 채웁니다. 비교할 두 번째 항목을 찾아서 선택하거나 파일 브라우저에서 파일이나 폴더를 끌어서 놓습니다.

  • MATLAB® 데스크탑홈(Home) 탭으로 이동한 후 파일(File) 섹션에서 비교(Compare)를 클릭합니다. 비교할 항목을 찾아서 선택하거나 파일 브라우저에서 파일이나 폴더를 끌어서 놓습니다.

  • 명령 창visdiff 함수를 사용합니다. 예를 들어, visdiff 함수와 디폴트 텍스트 비교를 사용하여 두 파일 lengthofline.mlengthofline2.m을 비교하려면 visdiff('lengthofline.m', 'lengthofline2.m')을 입력하십시오. MATLAB에서 비교 툴이 열리고 비교 결과 리포트가 표시됩니다.

두 파일과 폴더를 선택하는 것 외에도, 하나의 파일에 대해 현재 버전과 과거 버전을 비교할 수도 있습니다. 하나의 파일을 자동 저장 버전이나 디스크에 저장된 버전과 비교하려면 비교(Compare) 를 클릭하고 디스크 버전 비교(Compare with Version on Disk) 또는 저장 및 자동 저장과 비교(Save and Compare with Autosave)를 선택하십시오. 자세한 내용은 자동 저장 버전이나 디스크 버전과 파일 비교하기 항목을 참조하십시오. 라이브 스크립트나 라이브 함수에는 이러한 옵션을 사용할 수 없습니다.

비교 유형 선택하기

비교 툴은 선택한 항목에 대해 정의된 디폴트 비교 유형을 사용하여 항목을 비교합니다. 일부 항목 유형의 경우 디폴트 비교 유형과 다른 비교 유형을 사용자가 선택할 수 있습니다. 예를 들어, 텍스트, 이진, 파일 목록 또는 XML 비교 중에서 선택할 수 있습니다. 비교 유형을 변경하려면 비교할 파일이나 폴더를 선택한 다음 비교 유형(Comparison type) 메뉴의 옵션 중에서 선택하십시오. 비교 툴은 선택한 항목 유형에 대해 유효한 옵션만 표시합니다.

기존 비교 리포트에 대한 비교 유형은 변경할 수 없습니다. 비교 유형을 변경하려면 비교를 새로 시작하십시오.

비교할 두 파일이나 폴더를 지정할 때 현재 폴더 브라우저나 visdiff 함수를 사용했다면 비교 툴은 자동으로 디폴트 유형의 비교를 수행합니다. 예를 들어, 현재 폴더 브라우저에서 비교할 두 MAT 파일을 선택하는 경우 변수 관련 정보를 보여주는 디폴트 비교 유형을 사용하게 됩니다. 이 비교 유형을 이진수 비교로 변경하려면 비교 툴을 사용하여 새 비교를 만드십시오.

비교 리포트 탐색하기

비교하는 항목에 따라 다양한 방법으로 비교 리포트를 탐색할 수 있습니다.

  • 폴더, zip 파일 및 Simulink® 매니페스트 — 폴더, zip 파일 또는 Simulink 매니페스트의 조합을 비교하여 각 목록에 고유한 파일 이름과 폴더 이름을 확인합니다. 동일한 이름의 파일이나 폴더가 동일한 내용을 담고 있는지 여부를 식별할 수도 있습니다. 자세한 내용은 폴더, Zip 파일 및 Simulink 매니페스트 비교하기 항목을 참조하십시오.

  • 텍스트 — 두 텍스트 파일의 라인을 비교하고 병합합니다(다른 일부 응용 프로그램에서는 이를 파일 차이점 작업이라고 함). 자세한 내용은 텍스트 비교하기 및 병합하기 항목을 참조하십시오.

  • 라이브 코드 — 두 라이브 코드 파일에 있는 코드와 텍스트 라인을 비교하고 병합합니다. 자세한 내용은 라이브 코드 비교하기 및 병합하기 항목을 참조하십시오.

  • MAT 파일 — 두 MAT 파일의 변수를 비교하고 병합합니다. 자세한 내용은 MAT 파일 비교하기 및 병합하기 항목을 참조하십시오.

  • 이진 파일 — 두 이진 파일의 내용이 일치하는지 여부를 확인합니다. 자세한 내용은 이진 파일 비교하기 항목을 참조하십시오.

  • XML 파일 — 텍스트 비교나 계층적 XML 비교를 통해 XML 파일을 비교합니다. 자세한 내용은 XML 파일 비교하기 항목을 참조하십시오.

  • Simulink 모델 — Simulink가 있는 경우 Simulink 모델을 비교하고 병합합니다. 자세한 내용은 Model Comparison (Simulink) 항목을 참조하십시오.

폴더, Zip 파일 및 Simulink 매니페스트 비교하기

폴더, zip 파일, Simulink 매니페스트의 조합에 대해 파일 목록 비교를 수행할 수 있습니다. 예를 들어, 폴더의 내용을 zip 파일의 내용과 비교할 수 있습니다.

폴더 비교 리포트를 만들어 다음 작업을 수행합니다.

  • 공통 파일을 식별합니다.

  • 동일한 이름의 파일이나 폴더가 동일한 내용을 담고 있는지 확인합니다. 이러한 파일이나 폴더가 있으면 리포트에서 직접 해당 항목에 대한 자세한 비교 리포트를 열 수 있습니다.

비교할 파일이나 폴더 선택하기

비교할 항목을 선택하려면 비교할 파일이나 폴더 선택하기 항목을 참조하십시오. 비교할 항목을 선택할 때 하위 폴더 포함(Include Subfolders)을 선택하여 비교 리포트에 하위 폴더 내용을 포함하십시오.

차이점 탐색하기

파일 목록 비교를 수행하면 새 창이 열리고 지정한 목록의 내용이 나란히 표시됩니다. 다음 이미지는 두 폴더를 비교한 결과의 리포트 예입니다.

비교 툴은 아래 표에 설명된 대로, 일치하지 않는 파일이나 하위 폴더를 강조 표시합니다.

차이점 요약(Difference Summary)강조 표시 색설명
내용이 변경됨(contents changed)자주색파일이나 폴더의 내용이 다릅니다. 비교(Compare) 링크를 클릭하여 자세히 검토할 수 있습니다.
추가됨(Added)파란색 파일이나 폴더가 오른쪽 목록에만 있습니다.
제거됨(Removed)노란색파일이나 폴더가 왼쪽 목록에만 있습니다.
동일함(identical)없음파일이나 폴더가 동일합니다.

다음과 같은 여러 가지 방법으로 결과를 더 자세히 탐색할 수 있습니다.

  • 이름, 유형, 크기 또는 마지막으로 수정된 타임스탬프를 기준으로 결과를 정렬하려면 해당 열 제목을 클릭하십시오. 예를 들어, 유형(Type) 열 제목을 클릭하면 폴더 유형과 파일 형식을 기준으로 정렬됩니다.

  • 내용이 다른 항목에 대한 자세한 비교 리포트를 열려면 항목 옆의 비교(Compare) 링크를 클릭하십시오.

  • 파일을 편집기에서 열려면 파일 이름 옆에 있는 열기(Open) 링크를 클릭하십시오. 파일이 두 폴더 모두에 있는 경우 링크를 클릭해서 파일의 왼쪽(left) 버전이나 오른쪽(right) 버전을 열 수 있습니다.

  • 하위 폴더 용량이 매우 크고 하위 폴더에 들어 있는 파일이 많은 경우 백그라운드에서 분석이 계속 진행됩니다. 툴은 남은 비교 항목의 개수를 리포트 맨 위에 표시합니다. 현재 항목을 건너뛰려면 현재 항목 건너뛰기(Skip Current)를 클릭하고, 추가 분석을 중지하려면 모두 취소(Cancel All)를 클릭하면 됩니다.

비교 리포트를 추가로 구성하는 방법에 대한 자세한 내용은 비교 리포트 툴과 옵션 항목을 참조하십시오.

리포트 필터링하기

차이점을 검토하는 시간, 특히 다수의 하위 폴더를 비교하는 시간을 절약하려면 리포트를 필터링하면 됩니다. 필터를 만들려면 보기(View) 탭으로 이동하고 필터(Filter) 버튼을 클릭한 후 필터 추가/제거(Add/Remove Filter)를 선택하십시오. 백업 파일이나 개정 관리 시스템에서 만들어진 파일 등 특정 파일과 폴더를 무시하는 필터를 지정할 수 있습니다.

예를 들어, CVS라는 폴더에 있는 모든 파일과 폴더를 무시하려면 CVS/를 입력하십시오. CVS라는 폴더에 있는 모든 파일은 무시하나 하위 폴더는 무시하지 않으려면 CVS/*를 입력하십시오.

기존 필터를 편집하려면 필터를 더블 클릭하십시오.

텍스트 비교하기 및 병합하기

비교 툴을 사용하여 두 텍스트 파일의 라인을 비교하고 병합할 수 있습니다.

비교할 파일이나 폴더 선택하기

비교할 파일을 선택하려면 비교할 파일이나 폴더 선택하기 항목을 참조하십시오. 기본적으로, XML 파일은 텍스트 비교 기능을 사용하여 비교가 이루어집니다. 대신 계층적 비교를 통해 XML 파일을 비교하려면 XML 파일 비교하기 항목을 참조하십시오.

텍스트 비교를 수행하면 새 창이 열리고 두 파일이 나란히 표시됩니다. 표시되는 두 파일 사이의 다양한 기호를 통해 파일을 일치시키기 위해 어떻게 조정하면 되는지를 확인할 수 있습니다. 예를 들어, 예제 파일 lengthofline.mlengthofline2.m의 텍스트 비교를 보려면 다음 코드를 실행하십시오.

file1 = fullfile(matlabroot,'help','techdoc','matlab_env',...
'examples','lengthofline.m')
file2 = fullfile(matlabroot,'help',...
'techdoc','matlab_env','examples','lengthofline2.m')
visdiff(file1,file2)
비교 툴이 결과 리포트를 표시합니다.

차이점 탐색하기

비교 툴은 아래 표에 설명된 대로, 변경된 라인을 강조 표시합니다.

강조 표시 색설명
자주색라인의 내용이 두 파일 간에 다릅니다. 비교 툴이 두 라인 사이에 x를 표시합니다.
진한 자주색강조 표시된 문자가 두 라인 간에 다릅니다.
파란색라인이 오른쪽 파일에만 있습니다. 비교 툴이 두 라인 사이에 >를 표시합니다.
노란색라인이 왼쪽 파일에만 있습니다. 비교 툴이 두 라인 사이에 <를 표시합니다.

비교 툴은 라인이 일치하는지 확인하고 추가, 삭제, 변경된 텍스트를 검색합니다. 단순한 라인 단위 비교는 수행하지 않습니다. 예를 들어, lengthofline.mlengthofline2.m의 텍스트 비교에서 툴은 lengthofline.m에 없는 코드 라인이 lengthofline2.m에 있음을 확인한 후 이 차이점(라인 23)을 파란색으로 강조 표시합니다. 또한, 파일 간 end 문 일치 여부를 확인할 때는 추가 라인을 고려하여 라인 번호가 다르더라도 상관없이 end 문을 확인합니다.

비교할 파일이 아주 긴 경우에는 툴이 파일 비교를 수행하는 동안 메모리가 부족해질 수 있습니다. 이 경우 다음 메시지가 표시됩니다.

Maximum file length exceeded. Defaulting to line-by-line comparison.
이 경우 비교 툴은 라인 단위 비교로 전환합니다. 라인 단위 비교에서 툴은 이 비교 작업을 수행하는 동안 두 파일의 마지막 라인이 서로 일치하지 않음을 발견하므로 end 문이 포함된 라인을 강조 표시합니다.

다음과 같은 여러 가지 방법으로 결과를 더 자세히 탐색하고 구성할 수 있습니다.

  • 차이점 요약 보기 — 각 파일에서 일치하는 라인 수와 일치하지 않는 라인 수를 비롯하여, 두 텍스트 파일 사이의 차이점 요약을 보려면 비교 리포트의 맨 아래로 스크롤하십시오.

  • 공백 차이점 무시 — 공백 차이점을 숨기면 기능적 변경 사항과 들여쓰기 변경 사항을 구분하는 데 도움이 될 수 있습니다. 공백 문자와 관련된 차이점만 숨기려면 보기(View) 탭으로 이동하고 필터(Filter) 버튼을 클릭한 후 공백 무시(Ignore White Space)를 선택하십시오.

  • 차이점만 표시(Show Differences Only) — 차이점만 표시할지 전체 파일을 표시할지 지정하려면 보기(View) 탭으로 이동하고 필터(Filter) 버튼을 클릭한 후 차이점만 표시를 선택하거나 선택 취소하십시오. 큰 텍스트 비교 리포트에서는 차이점만 표시하는 것이 특히 유용합니다. 차이점만 표시하고 일부 라인이 숨겨지면 리포트에 숨겨진 라인 수를 나타내는 메시지가 표시됩니다. 예를 들어, 10개의 라인이 숨겨진 경우 리포트에는 10 unmodified lines hidden(10개의 수정되지 않은 라인이 숨겨짐)이라고 표시됩니다.

  • 표시 너비 변경 — 비교 표시에서 텍스트 파일의 라인 길이를 증가하거나 감소하려면 보기(View) 탭으로 이동하고 표시(Show) 섹션에서 열 너비(Column Width)를 변경하십시오. 필요한 경우 창 크기를 조정합니다.

  • HTML 리포트 저장 — 비교 리포트의 복사본을 HTML 파일로 저장하려면 비교(Compare) 탭으로 이동해 비교(Compare) 섹션에서 다른 이름으로 저장(Save As) > HTML을 클릭하십시오.

차이점을 순차적으로 확인하기

텍스트 파일이 길 경우 버튼과 버튼을 사용하여 결과에서 순차적으로 한 번에 하나씩 차이점을 확인하십시오. 마지막 차이점에 도달한 후 버튼을 클릭하면 파일에서 첫 번째 차이점으로 되돌아갑니다. 마찬가지로, 첫 번째 차이점을 선택하고 버튼을 클릭하면 비교 툴에서 파일의 마지막 차이점으로 이동합니다.

차이점 병합하기

텍스트 파일을 비교할 때 한 파일의 변경 사항을 다른 파일에 병합할 수 있습니다. 변경 사항 병합은 서로 다른 파일 버전 간의 충돌을 해결할 때 유용할 수 있습니다.

왼쪽에서 오른쪽으로만 병합할 수 있습니다. 왼쪽 파일로 병합하려면 병합을 시작하기 전에 좌우 전환(Swap Sides)을 사용하십시오. 좌우 전환(Swap Sides)은 이미 수행한 병합을 되돌리고 원래 파일에 대한 새 비교 리포트를 생성합니다.

왼쪽 파일에서 오른쪽 파일로 차이점을 병합하려면 리포트에서 차이점을 선택하고 비교(Compare) 탭에서 병합(Merge) 버튼을 클릭하십시오. 비교 툴에서 병합된 라인이 회색으로 강조 표시되고 녹색 병합 화살표가 표시됩니다.

리포트 상단의 병합된 파일 이름은 파일에 저장되지 않은 변경 사항이 들어 있음을 나타냅니다(filename.m*).

마지막 병합 작업을 되돌리려면 비교(Compare) 탭에서 실행 취소(Undo)를 클릭하십시오. 병합을 다시 적용하려면 다시 실행(Redo)을 클릭하십시오. 모든 병합을 되돌리고 다시 시작하려면 새로 고침(Refresh)을 클릭하십시오.

변경 사항을 저장하려면 병합된 파일 저장(Save Merged File)을 클릭합니다. 다른 이름으로 저장하려면 병합된 파일 저장(Save Merged File) > 다른 이름으로 병합된 파일 저장(Save Merged File As)을 선택하십시오.

편집기에서 파일을 보려면 리포트에서 라인 번호 링크를 클릭하십시오.

편집기에서 변경할 사항이 있다면 비교 리포트에서 병합 변경 사항을 먼저 저장한 후에 해야 합니다. 그러지 않으면 비교 리포트 내용이 올바르지 않게 될 수 있습니다. 리포트는 편집기에서 변경한 사항을 반영하기 위하여 업데이트되지 않습니다.

자동 저장 버전이나 디스크 버전과 파일 비교하기

편집기에 열려 있는 파일을 자동 저장 버전이나 저장 버전과 비교하도록 선택할 수 있습니다.

파일의 최신 버전을 편집기의 백업 복사본과 비교하려면 먼저 편집기에서 파일을 여십시오. 그런 다음, 편집기(Editor) 탭으로 이동하고 비교(Compare) 를 클릭한 후 저장 및 자동 저장과 비교(Save and Compare with Autosave)를 선택합니다. 파일이 수정되었다면 편집기가 비교를 수행하기 전에 먼저 파일을 저장합니다. 자세한 내용은 파일 백업 항목을 참조하십시오.

저장되지 않은 변경 사항이 있는 열린 파일을 저장된 버전과 비교하려면 편집기(Editor) 탭으로 이동하고 비교(Compare) 를 클릭한 후 디스크 버전 비교(Compare with Version on Disk)를 선택하십시오.

라이브 코드 비교하기 및 병합하기

라이브 코드 비교 리포트 생성하기

비교 툴을 사용하여 두 라이브 코드 파일의 라인을 비교하고 병합할 수 있습니다. 비교할 파일을 선택하려면 비교할 파일이나 폴더 선택하기 항목을 참조하십시오.

라이브 코드 비교를 수행하면 새 창이 열리고 두 파일이 나란히 표시됩니다. 예를 들어, 여러 가지 차이점이 있는 두 파일 averageweight.mlxaverageweight2.mlx가 있다고 가정하겠습니다. 두 파일을 비교하면 비교 툴이 결과 리포트를 표시합니다.

차이점 탐색하기

비교 툴에서 비교 리포트의 오른쪽 아래 코너에 차이점의 총 개수가 표시되고, 다음 표에 설명되어 있는 것처럼 일치하지 않는 라인이 강조 표시됩니다.

강조 표시 색설명
자주색라인의 내용이 두 파일 간에 다릅니다.
진한 자주색강조 표시된 문자가 두 파일 간에 다릅니다.
파란색라인이 오른쪽 파일에만 있습니다(오른쪽 파일에서의 삽입). 왼쪽 파일에서는 해당 라인이 회색 줄무늬로 강조 표시됩니다.
노란색라인이 왼쪽 파일에만 있습니다(오른쪽 파일에서의 삭제). 오른쪽 파일에서는 해당 라인이 회색 줄무늬로 강조 표시됩니다.

라이브 코드 파일을 비교하면, 비교 툴은 코드, 텍스트, 텍스트 서식의 차이점을 검출합니다. 파일에 출력값이 저장되어 있더라도 비교 툴에서는 출력값이 무시됩니다. 툴에서 수식, 이미지 또는 컨트롤 내의 차이점이 검색되는 경우 전체 항목이 강조 표시됩니다.

비교 툴은 라인이 일치하는지 확인하고 추가, 삭제, 변경된 코드와 텍스트를 검출합니다. 단순한 라인 단위 비교는 수행하지 않습니다. 예를 들어, averageweight.mlxaverageweight2.mlx의 라이브 코드 비교에서 비교 툴은 averageweight2.mlx에는 없는 두 라인의 코드가 averageweight.mlx에 있음을 확인하고(라인 5와 라인 7) 이를 노란색으로 강조 표시합니다. 또한, 파일 간 disp 문 일치 여부를 확인할 때는 추가 라인을 고려하여 라인 번호가 다르더라도 상관없이 disp 문을 확인합니다.

라이브 코드 파일이 길 경우 다음(Next) 버튼과 이전(Previous) 버튼을 사용하여 결과에서 순차적으로 한 번에 하나씩 차이점을 확인하십시오.

차이점 병합하기

라이브 코드 파일을 비교할 때 한 파일의 변경 사항을 다른 파일에 병합할 수 있습니다. 변경 사항 병합은 서로 다른 파일 버전 간의 충돌을 해결할 때 유용할 수 있습니다. 왼쪽에서 오른쪽으로만 병합할 수 있습니다. 왼쪽 파일로 병합하려면 병합을 시작하기 전에 좌우 전환(Swap Sides) 버튼을 클릭하십시오. 좌우 전환(Swap Sides) 버튼을 클릭하면 이미 수행한 병합이 되돌아가고 원래 파일에 대한 새 비교 리포트가 생성됩니다.

병합을 시작하려면 비교(Compare) 탭에서 병합 모드(Merge Mode) 버튼을 클릭하십시오. 그런 다음, 오른쪽 창의 내용을 왼쪽 창의 내용으로 바꾸려면 병합할 라인 옆에 있는 버튼을 클릭하십시오. 차이점을 선택하고 병합(Merge) 탭에서 내용 바꾸기(Replace Content) 버튼을 클릭할 수도 있습니다.

오른쪽 창에 병합된 결과가 포함됩니다. 오른쪽 창의 병합된 파일 이름 옆에 있는 별표(filename_modified.mlx*)는 파일에 저장되지 않은 변경 사항이 포함되어 있음을 나타냅니다.

바꾸기를 실행 취소하려면 수정된 라인 사이나 비교(Compare) 탭에서 버튼을 클릭하십시오. 모든 병합을 되돌리고 다시 시작하려면 새로 고침(Refresh) 버튼을 클릭하십시오. 라이브 편집기에서 파일을 변경하고 저장한 후에 새로 고침(Refresh) 버튼을 클릭하여 비교 리포트를 업데이트할 수도 있습니다. 새로 고치면 병합된 변경 사항이 모두 취소됩니다.

변경 사항을 저장하고 비교 리포트로 돌아가려면 결과 저장(Save Result) 버튼을 클릭하십시오. 변경 사항을 저장하지 않고 비교 리포트로 돌아가려면 비교로 돌아가기(Return to Comparison) 버튼을 클릭하십시오.

MAT 파일 비교하기 및 병합하기

MAT 파일 비교 리포트 생성하기

비교 툴을 사용하여 두 MAT 파일을 비교할 수 있습니다. 두 MAT 파일을 비교하여 다음 작업을 수행합니다.

  • 파일에 공통으로 나오는 변수와 고유한 변수를 파악합니다.

  • 개별 변수 간의 차이점을 식별합니다. 예를 들어, 구조체의 어떤 필드가 다른지 또는 배열의 어떤 요소가 다른지 확인할 수 있습니다.

비교할 항목을 선택하려면 비교할 파일이나 폴더 선택하기 항목을 참조하십시오.

MAT 파일 비교를 수행하면 새 창이 열리고 두 파일이 나란히 표시됩니다. 예를 들어, 두 MAT 파일 data1.matdata2.mat가 있다고 가정하겠습니다. 두 파일을 비교하면 비교 툴이 결과 리포트를 표시합니다.

차이점 탐색하기

비교 툴 리포트에서는 변수의 변경 사항이 다음 표에 설명된 대로 강조 표시됩니다.

차이점 요약(Difference Summary)강조 표시설명
수정됨(Modified)자주색두 파일 간에 변수의 값이 다릅니다. 비교(Compare) 링크를 클릭하여 자세히 검토할 수 있습니다. 자세한 내용은 변수 비교하기 항목을 참조하십시오.
추가됨(Added)파란색변수가 오른쪽 파일에만 있습니다.
제거됨(Removed)노란색변수가 왼쪽 파일에만 있습니다.
같음(Equivalent)없음두 파일의 변수가 같습니다. 이 툴은 NaN 패턴, 구조체의 필드 정렬 순서, 음수 0이나 양수 0의 차이를 무시합니다.
클래스가 변경됨(Class changed)자주색(클래스 열에서만)변수 데이터 클래스가 변경되었습니다. 비교(Compare) 링크를 클릭하여 자세히 검토할 수 있습니다.

두 파일의 변수가 같지만 파일은 같지 않은 경우 리포트에 메시지가 표시됩니다. 파일 간의 차이점이 발생할 수 있는 원인으로는 파일 형식, 파일 타임스탬프, 변수가 저장된 순서 등이 달라서일 수도 있고, 변수에 미미한 차이가 있어서일 수도 있습니다.

다음과 같은 여러 가지 방법으로 리포트에 있는 결과를 더 자세히 탐색할 수 있습니다.

  • 결과 정렬 — 이름, 크기, 클래스 또는 차이점 요약을 기준으로 결과를 정렬하려면 해당 열 제목을 클릭하십시오. 예를 들어, 클래스 유형을 기준으로 정렬하려면 클래스(Class) 열 제목을 클릭하십시오.

  • 변수 불러오기 — 변수의 내용을 변수 편집기로 불러오려면 해당 변수의 이름을 클릭하십시오.

  • MAT 파일 불러오기 — MAT 파일 중 하나를 작업 공간으로 불러오려면 리포트 아래쪽에 있는 해당 불러오기(Load) 링크를 클릭하십시오.

  • HTML 리포트 저장 — 리포트 복사본을 HTML 파일로 저장하려면 비교(Compare) 탭으로 이동하고 다른 이름으로 저장(Save As) > HTML을 클릭하십시오.

비교 리포트를 추가로 구성하는 방법에 대한 자세한 내용은 비교 리포트 툴과 옵션 항목을 참조하십시오.

변수 비교하기

변수 비교 리포트는 개별 배열 요소의 차이점이나 구조체의 필드를 표시합니다. 개별 차이점을 조사하려면 강조 표시된 행을 더블 클릭하십시오.

차이점 병합하기

MAT 파일을 비교할 때 한 파일의 변경 사항을 다른 파일에다 병합할 수 있습니다. MAT 파일을 병합할 때는 실행 취소 기능이 없으므로 병합할 때는 주의해야 합니다.

한 파일의 수정된 변수를 다른 파일로 복사하려면 비교(Compare) 탭의 병합(Merge) 섹션에서 병합(Merge) 버튼을 클릭하십시오.

이진 파일 비교하기

이진 비교 리포트 생성하기

비교 툴을 사용하여 DLL 파일 쌍이나 MEX 파일 쌍과 같은 이진 파일을 비교할 수 있습니다. 비교할 파일을 선택하려면 비교할 파일이나 폴더 선택하기 항목을 참조하십시오.

선택한 두 파일에 대해 디폴트 비교 대신 이진 비교를 수행할 수도 있습니다. 이진 비교를 사용하여 임의의 두 파일을 비교하려면 비교 유형(Comparison type)이진수 비교(Binary comparison)로 설정하십시오. 자세한 내용은 이진 파일 비교하기 항목을 참조하십시오.

이진 비교를 수행하면 새 창이 열리고 두 파일이 동일한지 다른지 여부가 표시됩니다. 파일이 다른 경우 세부 정보 표시(Show Details) 링크를 클릭하여 이진 파일을 보고 첫 번째 차이점의 바이트 오프셋을 확인하십시오.

비교 리포트 툴과 옵션

사용 가능한 툴과 옵션으로 비교 리포트를 추가로 탐색하고 구성할 수 있습니다.

  • 리포트의 좌우 전환 — 왼쪽 파일이나 폴더를 오른쪽 파일이나 폴더와 바꾸려면 비교(Compare) 탭으로 이동한 후 좌우 전환(Swap Sides) 버튼을 클릭하십시오.

  • 파일 업데이트 후 리포트 새로 고치기 — 편집기에서 파일을 변경하거나 저장한 후에 비교 툴에서 결과를 업데이트하려면 비교(Compare) 탭으로 이동한 후 새로 고침(Refresh) 버튼을 클릭하십시오.

  • 텍스트 찾기 — 현재 디스플레이에서 구를 찾으려면 비교(Compare) 탭으로 이동한 후 찾기(Find) 버튼을 클릭하십시오. 자세한 내용은 명령 창이나 명령 내역에서 텍스트 찾기 항목을 참조하십시오.

  • 색 기본 설정 변경 — 비교 툴의 색 기본 설정을 변경하고 저장하려면 다음을 수행하십시오.

    1. MATLAB 홈 탭에서 기본 설정(Preferences)을 클릭하고 MATLAB > 비교(Compare)를 선택합니다.

    2. 차이점, 수정된 라인, 수정된 내용, 병합된 라인에 원하는 색을 선택합니다. 색 기본 설정을 변경하면 활성화된 설정(Active settings)디폴트 값(수정됨)(Default (modified))이 표시됩니다.

    3. 적용(Apply)을 클릭하고 비교 리포트를 새로 고쳐, 업데이트되어 리포트에 반영된 색을 확인합니다.

    4. 수정된 색 기본 설정을 이후 MATLAB 세션에서 사용할 수 있게 저장하려면 다른 이름으로 저장(Save As)을 클릭하십시오. 색 설정 프로파일의 이름을 입력하고 확인(OK)을 클릭합니다.

      색 설정 프로파일을 저장한 후 활성화된 설정(Active settings) 목록에서 프로파일을 선택할 수 있습니다.

    5. 디폴트 설정을 복원하려면 재설정(Reset)을 클릭한 다음 적용(Apply)을 클릭하십시오. 비교 리포트를 새로 고칩니다.

    색 기본 설정은 모든 비교 유형에 적용됩니다.

소스 컨트롤

파일과 폴더의 비교와 병합에 MATLAB 비교 툴을 사용하도록 외부 소스 컨트롤 툴을 사용자 지정할 수 있습니다. 자세한 내용은 차이점 표시 및 병합에 MATLAB을 사용하도록 외부 소스 컨트롤 사용자 지정하기 항목을 참조하십시오.

참고 항목

관련 항목