Using zip('test', 'data.txt') Cannot open file "data.txt" for reading

조회 수: 5 (최근 30일)
Hi,
Just recently ugraded from Matlab 2018 to 2022 togehter with change to new computer. I have a GUI that zip several data files, like data..txt and .mat with test parameter and measureing data. I can't get the zip function working again. I have even tried just do a simple text file with numeric values but when I run zip('test', 'data.txt') I get "Cannot open file "data.txt" for reading, In zip (line 75)"
zip.m line 75: archive = matlab.io.internal.archive.core.builtin.createArchive(zipFilename,{entries.file},{entries.entry},mfilename);
I have no clue what is happening, does any of you out there explain what could be the reason?
Things I have tried:
Changed regional setting sicne we in nordic contries use , instead of . as decimal

채택된 답변

Vilém Frynta
Vilém Frynta 2023년 5월 2일
Hi, just an idea: since you are using a new computer, there may be a possibility that you do not have accurately described path for your files, or you do not have the permissions? Have you tried running Matlab as an administrator?
  댓글 수: 5
Vilém Frynta
Vilém Frynta 2023년 5월 4일
Glad I could assist with resolving your issue! I'd be happy if you could formally accept my answer. Thank you.

댓글을 달려면 로그인하십시오.

추가 답변 (0개)

카테고리

Help CenterFile Exchange에서 Environment and Settings에 대해 자세히 알아보기

제품


릴리스

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by