Main Content

이 번역 페이지는 최신 내용을 담고 있지 않습니다. 최신 내용을 영문으로 보려면 여기를 클릭하십시오.

PythonMATLAB Engine API에 대한 시스템 요구 사항

MATLAB®이 지원하는 모든 플랫폼에서 Python®용 MATLAB Engine API를 사용할 수 있습니다.

Python 버전 지원

Python용 MATLAB Engine API를 사용하려면 지원되는 버전의 Python 참조 구현(CPython이라고도 함)이 시스템에 설치되어 있어야 합니다. MATLAB은 버전 2.7, 3.7, 3.8을 지원합니다. 자세한 내용은 Versions of Python Compatible with MATLAB Products by Release를 참조하십시오.

Python을 다운로드하고 설치하려면 지원되는 Python 구현 설치하기 항목을 참조하십시오.

참고

Microsoft® Windows® 시스템에 64비트 MATLAB용 버전 2.7을 설치하려면 Windows x86-64 MSI Installer라는 64비트 Python 버전을 선택하십시오.

운영 체제 프롬프트에서 Python을 호출하려면 다음 중 하나를 수행하십시오.

  • PATH 환경 변수에 Python의 전체 경로를 추가합니다.

  • Python 인터프리터를 호출할 때 전체 경로를 포함시킵니다.

지원되는 버전을 호출하는 것인지 확인하려면 운영 체제 프롬프트에 python -V를 입력하여 Python 버전 번호를 표시하십시오.

Python 언어에 대한 도움말을 보려면 python.org 문서 www.python.org/doc를 참조하십시오. 타사 모듈이나 사용자 정의 모듈에 대한 도움말을 보려면 제품의 도움말 문서를 참조하십시오.

64비트 버전의 PythonMATLAB 다운로드하기

MATLAB의 아키텍처는 Python의 아키텍처와 일치해야 합니다. Python 다운로드 사이트에서 Microsoft Windows 플랫폼용 다운로드 파일은 기본적으로 32비트 버전입니다. 64비트 버전을 다운로드하려면 Windows x86-64 MSI installer라는 이름을 가진 옵션을 선택하십시오.

사용 중인 Python 버전이 32비트인지 64비트인지 테스트하려면 Python 프롬프트에 다음 코드를 입력하십시오.

import sys
print(sys.maxsize > 2**32)

이 코드는 Python 인터프리터가 64비트이면 True를 반환하고, 32비트이면 False를 반환합니다. (자세한 내용은 Python 2.7 Documentation — Cross Platform을 참조하십시오.)

소스에서 Python을 빌드하기 위한 요구 사항

Linux®에서 Python 2.7에 대해 와이드 유니코드 지원을 활성화하려면 --enable-unicode=ucs4 옵션을 사용하여 빌드를 구성하십시오. Mac 시스템에서 임의 버전의 Python을 빌드하거나 Linux에서 Python 3.x를 빌드할 경우에는 이 구성 옵션이 필요하지 않습니다.

관련 항목

외부 웹 사이트