이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

hgsave

파일에 그래픽스 객체 계층 구조 저장

구문

hgsave(filename)
hgsave(h,filename)
hgsave(...,'-v6')
hgsave(...,'-v7.3')

설명

참고

hgsave는 권장되지 않습니다. savefig를 대신 사용하십시오.

hgsave(filename)은 현재 Figure를 filename이라는 파일에 저장합니다. filename을 문자형 벡터나 string형으로 지정합니다.

hgsave(h,filename)은 핸들 배열 h로 식별되는 객체를 파일 filename에 저장합니다. filename의 확장자를 지정하지 않으면 확장자 .fig가 추가됩니다. h가 벡터인 경우에는 h의 어떤 핸들도 h에서 다른 핸들의 선조 또는 후손이 될 수 없습니다.

hgsave(...,'-v6')는 MATLAB® 7 이전 버전에 의해 불러올 수 있는 형식으로 FIG 파일을 저장합니다.

hgsave(...,'-v7.3')는 MATLAB 버전 7.3 이상에 의해서만 불러올 수 있는 형식으로 FIG 파일을 저장합니다. HDF5 파일을 기반으로 하는 이 형식은 2GB보다 큰 FIG 파일을 저장하기위한 것입니다.

이전 버전과의 호환성

저장하려는 Figure를 생성하여 MATLAB 7 이전 버전의 MATLAB에서 사용하는 경우, 플로팅 함수에 'v6' 옵션을, hgsave'-v6' 옵션을 사용합니다. 사용하려는 플로팅 함수에 대한 자세한 내용은 함수 도움말 페이지를 확인하십시오.

MATLAB 릴리스 R2014b 이상에서는 이전 버전의 MATLAB에서 저장된 FIG 파일을 열 수 없습니다. 이전 버전의 MATLAB과 호환 가능한 Figure를 저장하려면 savefig를 사용하십시오.

대안

파일 > 내보내기 설정 대화 상자를 사용합니다. 편집 > Figure 복사를 사용하여 Figure의 내용을 시스템 클립보드에 복사합니다. 자세한 내용은 저장하기 전에 Figure를 대화형 방식으로 사용자 지정하기 항목과 편집 메뉴에서 Figure를 클립보드로 복사하기 항목을 참조하십시오.

참고 항목

| | |

R2006a 이전에 개발됨