Simulink unable to load bundle binary

조회 수: 128(최근 30일)
Johnny Hung
Johnny Hung 2021년 5월 21일
편집: Tong Zhao 2022년 2월 16일
I recently upgraded my workstation to Alma Linux (a fork of RHEL8) and installed MATLAB R2020b. MATLAB works fine but when I try to use Simulink I get the following error:
Unable to load bundle binary /usr/local/MATLAB/R2020b/bin/glnxa64/builtins/sl_graphical_classes/
Error: /lib64/ undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b: Success
I found some thread of people having similar errors (not necessary with Simulink though) and they were able to solve it by removing the copy of which comes with MATLAB (<MATLABROOT>/bin/glnxa64/ then creating a symbolic link which points to the from the OS itself (/lib64/ When I tried that, MATLAB would open and then immediately close with the following error:
*** buffer overflow detected ***: /usr/local/MATLAB/R2020b/bin/glnxa64/MATLAB terminated
Segmentation fault
Has anyone seen this before? Any advice would be much appreciated.
  댓글 수: 1
HiWave 2021년 7월 26일
I'm having the same issue:
Unable to load bundle binary /bin/glnxa64/builtins/sl_graphical_classes/ Error: /lib64/ undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b: Success
Linux RHEL 8.3
Matlab 2020b
I've uninstalled by removing everything (installed directory and .matlab directory). Following reinstall, it still didn't work.

댓글을 달려면 로그인하십시오.


HiWave 2021년 7월 26일
OK...this isn't necessarily THE solution, but it does appear to solve my problem. I started by removing the files
rm -rf <MATLABROOT>/bin/glnxa64/*
in order to install Matlab (solves install issues). In this case "<MATLABROOT>" is the directory where you're running the installer from. After it installs, Matlab should start up without a problem. At the Matlab command promt, type in "simulink" (or launch from icon) and it will fail with the error shown above.
The solution appears to be that you need to remove the* files POST installation as well. I don't know much about the install process, but again, this worked for me. Go to where you installed Matlab. It will also contains a "/bin/glnxa64/" directory structure. Inside there, you need to remove the files
rm -rf <MATLABROOT>/bin/glnxa64/*
in which "<MATLABROOT>" is the installation directory, not where you ran the installer from. Simulink now starts.
  댓글 수: 1
Tong Zhao
Tong Zhao 2022년 2월 16일
편집: Tong Zhao 2022년 2월 16일
Thanks for sharing, this may be a stupid question: I have the same issue as the OP and you, but I simply cannot delete any files from the <MATLABROOT> as I am running the program on a cluster, and I do not have the rights to delete files. Do you know of an alternative way, maybe blocking the particular file from MATLAB search path? Thanks.
OS: Linux CentOS 8 (a RedHat variant of Linux)

댓글을 달려면 로그인하십시오.


Find more on Introduction to Installation and Licensing in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by