MATLAB Answers

I can't use "structuralProperties" in PDE toolbox

조회 수: 19(최근 30일)
JeongHyun Kim
JeongHyun Kim 2020년 7월 23일
댓글: JeongHyun Kim 2020년 7월 23일
Hi, I'm using MATLAB R2020a with PDE toolbox version 3.4 and my licenses are activated.
I wrote some short codes:
thePde = createpde();
model = importGeometry(thePde,'filename.stl');
pdegplot(model,'FaceLabels','on')
structuralProperties(model,'YoungsModulus',400e9,'PoissonsRatio',0.34);
structuralBC(model,'Face',36,'Constraint','fixed');
structuralBoundaryLoad(model,'Face',37,'SurfaceTraction',[0;0;-1e4]);
this is all(6 lines), I tried to
  1. import my 3D object CAD file "filename.stl" and graphically show it
  2. before doing finite element analysis, I tried to assign structural properties, boundary conditions.
The first one(importing&visuallizing) had no problem. But I have a trouble for second one, line 4~6 in codes:
Unrecognized function or variable 'structuralProperties'.
this is the error message I received after running. Also same errors for 'structuralBC' and 'structuralBoundaryLoad'. Now I am guessing that there is a problem in calling function, but I am not sure. What could be the problem?
Thanks for your advice.
  댓글 수: 2
JeongHyun Kim
JeongHyun Kim 2020년 7월 23일
Actually, I already tried 'rehash toolboxcache' but it didn't worked.
I'll try manually adding the source code path. Thanks for your advice. I really appreciate it

댓글을 달려면 로그인하십시오.

채택된 답변

Ravi Kumar
Ravi Kumar 2020년 7월 23일
Change the line:
thePde = createpde();
to
thePde = createpde('structural');
By default, createpde returns a model that has to deal with general equations-based interface. For structural analysis you need to specify the first argument as 'structural', this will create a structural analysis model for static analysis. If you want to do other types of structural analysis, then you need to pass a second argument that specifies analysis type. Check the options in createpde documentation page.
Regards,
Ravi
  댓글 수: 1
JeongHyun Kim
JeongHyun Kim 2020년 7월 23일
Thanks a lot. Today, I additionally recognized the problem. I changed line 1 to
thePde = createpde('structural','static-solid');
as you adviced,
and I also found my mistakes of using wrong variable for structural~ functions.
It had to be
structuralProperties(thePde,'YoungsModulus',...
not
structuralProperties(model,'YoungsModulus',...
and now everything is okay.
Again, thanks for your advice. I really appreciate it.

댓글을 달려면 로그인하십시오.

추가 답변(0개)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by