Randi worked in a program I ran 5 weeks ago, today it doesn't-what gives?

조회 수: 1(최근 30일)
Fede C 2018 London
Fede C 2018 London 2019년 10월 17일
댓글: Guillaume 2019년 10월 17일
Dear all,
I had a perfectly-functioning program that used this line:
c = randi([1,n],mn,1)
where n and mn are integers. I've re-opened the program to do a monte carlo simulation, and all I get is an error message stating:
Error using randi
Too many input arguments.
Mind you, I haven't changed a coma in the program. I'm just running it again to re-acquaint myself with had I had done.
Any thoughts?

채택된 답변

John D'Errico
John D'Errico 2019년 10월 17일
편집: John D'Errico 2019년 10월 17일
Don't write an m-file that is named randi, at least, if you will ever want to use randi. Try this:
which randi -all
If there is a function named randi that you created, then you did exactly that.
In general, avoid naming functions with existing function names. Check BEFORE you create that file.
  댓글 수: 6
Guillaume
Guillaume 2019년 10월 17일
It appears you're using this toolbox. Delete it or at least remove it from your path since it shadows built-in functions randi and rng and maybe more.
I would also recommend getting in touch with them to complain about that shadowing.

댓글을 달려면 로그인하십시오.

추가 답변(0개)

태그

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by