Why does the Update Installer fail with no clear error message shown in the log file?

조회 수: 31(최근 30일)
When trying to install the R2017b Updates the installation process terminates with the message:
Installation failed [1]
There is no other clear indicator of what may be causing the issue. How can I resolve the issue?

채택된 답변

MathWorks Support Team
MathWorks Support Team 2019년 11월 4일
편집: MathWorks Support Team 2019년 11월 4일
If the updater installation log file does not show any clear indicator of what is causing the issue, do a search for "skipping" in the log file.
For example, in several cases there are mentions of the Simulink Real Time Toolbox being skipped:
Need to update: toolbox/slrt/target/kernel/XXXXX
Warning: File on disk does not match expected meta data
Warning: meta size: 1526446 meta time: 1503595432 (orig)
Warning: meta size: 1526449 meta time: 1512792246 (new)
Warning: disk size: 1527326 disk time: 1521632126
Warning: Skipping update
This usually means that the file being looked at was modified. There are two recommended solutions to this:
1) Try reinstalling the toolbox that is affected and then apply the update to a clean installation.
2) Try running the update as an administrator account as permissions issues will also appear as this error.
  댓글 수: 1
Royi Avital
Royi Avital 2018년 7월 14일
Reinstalling is a mess. Any option to add `force` mode to the updater?
I have this issue for update 4 of R2018a on Linux. The installation of MATLAB is a folder which requires root for write permission. The only program touched those files was Update 3.

댓글을 달려면 로그인하십시오.

추가 답변(4개)

Justin Ghetti
Justin Ghetti 2018년 7월 19일
Hi,
If you are still experiencing this issue, please contact MathWorks support:
-Justin
  댓글 수: 2
Kyle Perry
Kyle Perry 2018년 8월 1일
Hello Royi,
Currently there is not, I am forwarding this request internally for future reference though.

댓글을 달려면 로그인하십시오.


kira
kira 2018년 8월 8일
hello, same issue here!!! Any fix?

James Macdonald
James Macdonald 2019년 4월 1일
Turn off your anti-virus software and reinstall Matlab. On my system, the anti-virus software was altering the date modified timestamps at installation, which was triggering the meta data check to fail when trying to update Matlab.

Faheem Ershad
Faheem Ershad 2019년 10월 29일
So I went into the log file and searched for the "Skipping update" line as the support team suggested. For my case, I was getting the "Skipping" a couple lines after a line that listed this as the problematic directory:
bin/win64/connector_plugins/connector/rest_matlab/libmwconnectorrestmatlabactivator.dll
That's in your MATLAB/r2018a/ folder by the way.
I went into that directory and saw that there was a -OLD addition at the end of the .dll file. In other words, the file in that directory was named this:
libmwconnectorrestmatlabactivator.dll-OLD
I copied that file in the same directory and removed the -OLD from the end so that the file name ended with the .dll extension. I ran the update installer again and it worked!
Just for context, I was trying to update r2018a (update 1 I believe) to r2018a update 6.

제품


릴리스

R2018a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by