MATLAB Answers

R2017a arduino_gettingstarted compilation error

조회 수: 4(최근 30일)
I have followed the getting started instructions but get this compiler error: C:/ProgramData/MATLAB/SupportPackages/R2017a/toolbox/target/supportpackages/arduinotarget/registry/../src/MW_ArduinoHWInit.cpp:33:43: error: 'Serial_begin' was not declared in this scope Serial_begin(0, RTT_BAUDRATE_SERIAL0); ^ gmake: * [MW_ArduinoHWInit.o] Error 1 ### Build procedure for model: 'arduino_gettingstarted' aborted due to an error. I am connected to a Mega 2560 and have configured the model for this.
The MATLAB and Simulink HW Support Packages are installed and I have installed the MinGW64 compiler: 'MEX configured to use 'MinGW64 Compiler (C)' for C language compilation.' What am I missing?

  댓글 수: 0

로그인 to comment.

채택된 답변

Pradeep KS
Pradeep KS 4 Apr 2017
Hi Justin, Please check if the installed path has this folder: C:\ProgramData\MATLAB\SupportPackages\R2017a\toolbox\target\supportpackages\arduinobase\src

  댓글 수: 4

표시 이전 댓글 수: 1
Justin Mellor
Justin Mellor 5 Apr 2017
I have added everything to the path that is in this folder, and below, but still get the same error: C:\ProgramData\MATLAB\SupportPackages\R2017a\toolbox\target\supportpackages.
I assume other people are working successfully with 2017a and an Arduino?
Gaurav Ahuja
Gaurav Ahuja 6 Apr 2017
If you found that path missing, it is highly likely the installation of the support package did not complete successfully or got corrupted due to some reason.
It would be recommended if you reinstall the support package again after manually deleting all the files related to the support package.
Step 1. Delete the CONTENTS of "SupportPackages" folder related to your support package, located inside the following MATLAB folder.
C:\ProgramData\MATLAB\SupportPackages\R2017a\toolbox\target\supportpackages\
Step 2: At the MATLAB command prompt, type "supportPackageInstaller".
Step 3: Find the required package and install it again.
Then confirm if installation completes successfully and there is still the same issue.
Justin Mellor
Justin Mellor 6 Apr 2017
Thank you Guarav - that has worked! I removed both the MATLAB and Simulink Hardware Support Packages and just re-installed the Simulink Package at the moment (not sure if the MATLAB package has anything to do with).

로그인 to comment.

추가 답변(0개)

이 질문에 답변하려면 로그인을(를) 수행하십시오.


Translated by