이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

그래픽스 인쇄

인쇄 개요

컴퓨터에 연결된 프린터에서 바로 MATLAB® Figure를 인쇄할 수도 있고 MATLAB에서 지원하는 표준 그래픽스 파일 형식 중 하나로 Figure를 내보낼 수도 있습니다. Figure를 인쇄하고 내보내는 방법에는 두 가지가 있습니다.

  • 파일(File) 메뉴에서 인쇄(Print), 인쇄 미리보기(Print Preview), 내보내기 설정(Export Setup) 옵션 중 하나를 사용합니다.

  • 명령줄에서 print 명령을 사용하여 Figure를 인쇄하거나 내보냅니다.

print 명령을 사용하면 드라이버와 파일 형식을 보다 세부적으로 제어할 수 있습니다. 인쇄 미리보기 대화 상자에서 Figure 크기, 비율, 배치, 페이지 머리글을 좀 더 세밀하게 조정할 수 있습니다.

파일 메뉴에서 인쇄

파일(File) 메뉴에는 인쇄와 관련된 다음과 같은 두 가지 메뉴 옵션이 있습니다.

  • 인쇄 미리보기(Print Preview) 옵션을 선택하면 출력 페이지를 미리 보면서 인쇄할 Figure의 레이아웃과 스타일을 지정할 수 있는 대화 상자가 표시되며, 여기서 바로 Figure를 인쇄할 수 있습니다. 여기에는 이전에 페이지 설정 대화 상자의 일부였던 옵션도 포함되어 있습니다.

  • 인쇄(Print) 옵션을 선택하면 프린터와 표준 인쇄 옵션을 선택하고 Figure를 인쇄할 수 있는 대화 상자가 표시됩니다.

인쇄 미리보기(Print Preview)를 사용하여 원하는 내용으로 출력되는지 확인합니다. 인쇄 미리보기 대화 상자의 도움말(Help) 버튼을 클릭하여 페이지 설정 방법에 관한 정보를 표시합니다.

Figure를 그래픽스 파일로 내보내기

파일(File) 메뉴의 내보내기 설정(Export Setup) 옵션을 선택하면 그래픽스 파일로 저장하는 Figure에 대해 텍스트 크기, 글꼴, 스타일 같은 그래픽 특성을 설정할 수 있도록 하는 UI가 열립니다. 내보내기 설정 대화 상자에서는 템플릿을 정의하고 적용하여 출력을 사용자 지정하고 표준화할 수 있습니다. 설정 후에는 Figure를 다양한 표준 그래픽스 파일 형식(예: EPS, PNG, TIFF)으로 내보낼 수 있습니다.

Print 명령 사용

print 명령을 사용하면 프린터로 전송되는 출력의 유형을 보다 자유롭게 지정할 수 있고, 함수 파일과 스크립트 파일에서 인쇄하는 것을 제어할 수 있습니다. 결과물은 디폴트 프린터로 직접 전송할 수도 있고 지정한 출력 파일에 저장할 수도 있습니다. TIFF, JPEG, PNG를 포함한 다양한 출력 형식을 사용할 수 있습니다.

예를 들어, 다음 명령문은 현재 Figure 창의 내용을 magicsquare.png라는 파일에 PNG 그래픽으로 저장합니다.

print -dpng magicsquare.png

Figure를 화면에 나타난 Figure와 동일한 크기로 저장하려면 다음 명령문을 사용하십시오.

set(gcf,'PaperPositionMode','auto')
print -dpng -r0 magicsquare.png

동일한 Figure를 해상도가 200dpi인 TIFF 파일로 저장하려면 다음 명령을 사용하십시오.

print -dtiff -r200 magicsquare.tiff

명령줄에 print를 입력하면

print

현재 Figure가 디폴트 프린터에서 인쇄됩니다.