이 페이지의 최신 내용은 아직 번역되지 않았습니다. 최신 내용은 영문으로 볼 수 있습니다.

GUIDE UI용 도구 모음 만들기

도구 모음 및 툴

UI에 도구 모음을 추가하려면 도구 모음 편집기를 선택하십시오.

툴(Tools) 메뉴에서 도구 모음 편집기를 열 수도 있습니다.

도구 모음 편집기를 통해 uitoolbar, uipushtool, uitoggletool 함수의 모든 기능에 대화형 방식으로 액세스할 수 있습니다. 도구 모음 편집기는 GUIDE 범주 내에서만 유효합니다. 즉, 도구 모음 편집기를 사용하여 MATLAB® 내장 도구 모음을 수정할 수 없습니다. 그러나 GUIDE의 UI에서는 도구 모음 편집기를 통해 도구 모음을 추가, 수정, 삭제할 수 있습니다.

현재는 GUIDE의 UI에 도구 모음을 한 개 추가할 수 있습니다. 하지만 사용자가 만드는 UI는 표준 MATLAB Figure 도구 모음을 포함할 수도 있습니다. 필요한 경우 일반 Figure 도구 모음처럼 보이는 도구 모음을 생성하되, 툴(예: 패닝, 확대/축소 및 열기)이 특정 방식으로 동작하도록 콜백을 사용자 지정할 수 있습니다.

참고

UI에 단순히 표준 Figure 도구 모음을 포함시키고자 할 경우 도구 모음 편집기를 사용할 필요가 없습니다. 다음과 같이 Figure의 ToolBar 속성을 'figure'로 설정하면 됩니다.

  1. GUIDE에서 UI를 엽니다.

  2. 보기(View) 메뉴에서 속성 인스펙터(Property Inspector)를 엽니다.

  3. 드롭다운 메뉴를 사용하여 ToolBar 속성을 'figure'로 설정합니다.

  4. Figure를 저장합니다.

나중에 Figure 도구 모음을 제거하려면 ToolBar 속성을 'auto'로 설정하고 UI를 다시 저장하면 됩니다. 이렇게 해도 사용자 지정 도구 모음이 제거되거나 숨겨지지 않습니다. 도구 모음을 직접 만드는 방법에 대한 자세한 내용은 Create Toolbars for Programmatic Apps 항목을 참조하십시오.

사용자가 MATLAB 데스크탑에서 UI 창을 도킹 및 도킹 해제할 수 있도록 하려면 표준 도구 모음 또는 메뉴 모음 혹은 GUIDE에서 만든 도구 모음 또는 메뉴 모음이 있어야 합니다. 또한, Figure 속성 DockControls가 활성화되어 있어야 합니다. 자세한 내용은 메뉴가 Figure 도킹에 미치는 영향 항목을 참조하십시오.

도구 모음 편집기 사용하기

도구 모음 편집기는 다음과 같이 세 가지 주요 부분으로 구성됩니다.

  • 상단의 도구 모음 레이아웃(Toolbar Layout) 미리보기 영역

  • 왼쪽의 툴 팔레트(Tool Palette)

  • 오른쪽의 두 개의 탭 속성 창

툴을 추가하려면 툴 팔레트(Tool Palette)에서 도구 모음 레이아웃(Toolbar Layout)(이는 기본적으로 위에 보여지는 텍스트 프롬프트를 포함합니다)으로 아이콘을 끌어서 놓은 후 툴 속성(Tool Properties) 창에서 툴의 속성을 편집하십시오.

UI를 처음 생성하면 도구 모음이 UI에 없습니다. 도구 모음 편집기를 열고 툴을 처음으로 추가하면 도구 모음이 생성되고 방금 추가한 툴의 미리보기가 창의 맨 위에 표시됩니다. 나중에 도구 모음이 있는 UI를 열면 레이아웃 편집기에 기존 도구 모음이 표시되지 않더라도 도구 모음 편집기에는 표시됩니다.

툴 추가하기

툴을 도구 모음에 추가하는 방법에는 세 가지가 있습니다.

  • 툴 팔레트(Tool Palette)에서 툴을 끌어서 놓습니다.

  • 팔레트에서 툴을 선택하고 추가(Add) 버튼을 클릭합니다.

  • 팔레트에서 툴을 더블 클릭합니다.

끌어서 놓는 방법을 사용하면 도구 모음에 원하는 순서대로 툴을 배치할 수 있습니다. 다른 두 방법에서는 도구 모음 레이아웃(Toolbar Layout)에서 맨 오른쪽 툴의 오른쪽에 툴이 배치됩니다. 새 툴이 선택되고(툴 주위의 파선 상자로 선택 여부가 표시됨) 해당 속성이 툴 속성(Tool Properties) 창에 표시됩니다. 툴은 한 번에 하나만 선택할 수 있습니다. 컴퓨터 키보드의 탭 키나 화살표 키를 사용하여 툴 팔레트(Tool Palette)를 순환할 수 있습니다. 도구 모음에 적어도 하나의 툴이 배치되어 있어야 합니다.

툴 팔레트(Tool Palette)에서 도구 모음 레이아웃(Toolbar Layout) 영역으로 툴을 배치하고 나면 다음 그림에서 보이는 것처럼 도구 모음 편집기에 현재 선택된 툴의 속성이 표시됩니다.

미리 정의된 툴과 사용자 지정 툴

도구 모음 편집기는 다음과 같은 두 가지 유형의 툴을 제공합니다.

  • 미리 정의된 툴 - 표준 아이콘 및 동작을 제공함

  • 사용자 지정 툴 - 일반 아이콘을 제공하되 동작은 제공하지 않음

미리 정의된 툴.  툴 팔레트의 아래쪽에 있는 아이콘 세트는 표준 MATLAB Figure 툴을 나타냅니다. 이러한 툴의 동작은 내장되어 있습니다. 좌표축을 필요로 하는 미리 정의된 툴(예: 패닝 및 확대/축소)은 좌표축이 없는 UI에서는 동작하지 않습니다. 미리 정의된 툴의 동작을 정의하는 콜백은 %default로 표시되는데, 이는 파일 열기, Figure 저장, 모드 변경 등을 위해 표준 Figure 도구 모음 및 메뉴에서 툴이 호출하는 것과 같은 함수를 호출합니다. %default를 일부 다른 콜백으로 변경하여 툴을 사용자 지정할 수 있습니다. 사용자가 콜백 필드를 변경하거나 콜백 필드 옆에 있는 보기 버튼을 클릭하는 경우 GUIDE는 툴의 동작이 수정된다는 경고 메시지를 표시하고 계속할지 여부를 묻습니다.

사용자 지정 툴.  툴 팔레트 상단의 두 개의 아이콘은 푸시 툴과 토글 툴을 생성합니다. 이들 툴은 클릭하여 선택 또는 해제했을 때 외형이 변하는 것 말고는 내장된 동작이 없습니다. 따라서 도구 모음에 툴을 추가할 때 고유한 콜백을 제공해야 합니다. 사용자 지정 툴이 클릭에 응답하게 하려면 콜백을 편집하여 원하는 동작을 생성해야 합니다. 툴 속성(Tool Properties) 창의 콜백 옆에 있는 보기(View) 버튼을 클릭한 후 편집기 창에서 콜백을 편집하면 됩니다.

구분선 추가 및 제거하기

구분선은 툴을 구분하는 세로 막대입니다. 이를 통해 툴을 시각적으로 그룹화할 수 있습니다. 구분선을 추가 또는 제거하는 방법에는 세 가지가 있습니다.

  • 툴의 미리보기를 마우스 오른쪽 버튼으로 클릭하고, 구분선을 설정 또는 해제하는 구분선 표시(Show Separator)를 선택합니다.

  • 툴의 속성 창에서 왼쪽에 구분선(Separator) 체크박스를 선택하거나 선택 취소합니다.

  • 속성 인스펙터에서 툴의 Separator 속성을 변경합니다.

구분선을 추가하면 도구 모음 레이아웃(Toolbar Layout)에서 툴의 왼쪽에 구분선이 표시됩니다. 구분선은 별개의 객체 또는 아이콘이 아니라 툴의 속성입니다.

툴 이동하기

다음 두 가지 방법으로 도구 모음의 툴을 재정렬할 수 있습니다.

  • 툴을 새 위치로 끌어서 놓습니다.

  • 도구 모음에서 툴을 선택하고 도구 모음의 오른편 밑에 있는 화살표 버튼 중 하나를 클릭합니다.

툴의 왼쪽에 구분선이 있는 경우 구분선도 툴과 함께 움직입니다.

툴 제거하기

다음 세 가지 방법으로 도구 모음에서 툴을 제거할 수 있습니다.

  • 툴을 선택하고 Delete 키를 누릅니다.

  • 툴을 선택하고 삭제(Delete) 버튼을 클릭합니다.

  • 툴을 마우스 오른쪽 버튼으로 클릭하고 상황별 메뉴에서 삭제(Delete)를 선택합니다.

이러한 동작은 실행 취소할 수 없습니다.

툴의 속성 편집하기

툴 속성(Tool Properties) 창을 사용하여 현재 선택한 툴의 모양과 동작을 편집할 수 있습니다. 이 창에는 다음과 같이 가장 일반적으로 사용되는 툴의 속성을 설정하는 컨트롤이 포함되어 있습니다.

  • CData — 툴의 아이콘

  • 태그 — 툴의 내부 이름

  • 이 툴 활성화 — 사용자가 툴을 클릭할 수 있는지 여부

  • 왼쪽에 구분선 — 툴을 분리하고 그룹화하기 위해 아이콘 왼쪽에 표시되는 막대

  • 클릭 때 콜백 — 사용자가 툴을 클릭할 때 호출되는 함수

  • 끌 때 콜백(uitoggletool만 해당) — 툴이 꺼짐 상태로 전환될 때 호출되는 함수

  • 켤 때 콜백(uitoggletool만 해당) — 툴이 켜짐 상태로 전환될 때 호출되는 함수

툴 콜백을 프로그래밍하는 방법에 대한 자세한 내용은 GUIDE에서 콜백 작성하기 항목을 참조하십시오. 속성 인스펙터를 사용하여 이들 속성 및 선택한 툴의 다른 속성에 액세스할 수도 있습니다. 속성 인스펙터를 열려면 툴 속성(Tool Properties) 창에서 추가 속성(More Properties) 버튼을 클릭하십시오.

툴 아이콘 편집하기

선택한 도구 모음 아이콘을 편집하려면 툴 속성(Tool Properties) 창에서 CData(아이콘)(CData(icon)) 옆에 있는 편집(Edit) 버튼을 클릭하거나 도구 모음 레이아웃(Toolbar Layout)을 마우스 오른쪽 버튼으로 클릭하고 상황별 메뉴에서 아이콘 편집(Edit Icon)을 선택하십시오. 툴의 CData를 불러온 상태로 아이콘 편집기가 열립니다. 아이콘 편집에 대한 자세한 내용은 아이콘 편집기 사용하기 항목을 참조하십시오.

도구 모음 속성 편집하기

도구 모음에서 빈 부분을 클릭하거나 도구 모음 속성(Toolbar Properties) 탭을 클릭하면 다음과 같은 두 속성을 편집할 수 있습니다.

  • Tag — 도구 모음의 내부 이름

  • Visible — 도구 모음이 UI에 표시되는지 여부

Tag 속성은 기본적으로 uitoolbar1로 설정되어 있습니다. Visible 속성은 on으로 설정되어 있습니다. Visible 속성이 on으로 설정된 경우 Figure의 Toolbar 속성 설정에 상관없이 도구 모음이 UI에 표시됩니다. 내장 도구 모음과 같이 보기(View) 메뉴에서 사용자 지정 도구 모음을 전환하려는 경우 메뉴 항목, 체크박스 또는 기타 컨트롤을 생성하여 Visible 속성을 제어할 수 있습니다.

추가 속성(More Properties)을 클릭하면 속성 인스펙터에서 도구 모음에 대한 거의 모든 속성에 액세스할 수 있습니다.

도구 모음 테스트하기

도구 모음을 시험해 보려면 레이아웃 편집기에서 실행(Evaluate) 버튼을 클릭하십시오. 먼저 변경 사항을 .fig 파일에 저장할지 묻는 메시지가 표시됩니다.

도구 모음 제거하기

도구 모음 편집기에서 도구 모음을 완전히 제거(삭제)하여 (기본적으로 표시되지 않는 Figure 도구 모음 이외의)도구 모음 없는 UI를 만들 수 있습니다. 도구 모음을 제거하는 방법은 두 가지가 있습니다.

  • 도구 모음의 오른쪽 끝에 있는 제거(Remove) 버튼 을 클릭합니다.

  • 도구 모음에서 빈 영역을 마우스 오른쪽 버튼으로 클릭하고 상황별 메뉴에서 도구 모음 제거(Remove Toolbar)를 선택합니다.

도구 모음 자체를 제거하지 않고 툴 제거하기에 설명된 방법으로 모든 개별 툴을 제거하면 UI에 빈 도구 모음이 포함됩니다.

도구 모음 편집기 닫기

다음 두 가지 방법으로 도구 모음 편집기 창을 닫을 수 있습니다.

  • 확인(OK) 버튼을 누릅니다.

  • 제목 표시줄에서 닫기 상자를 클릭합니다.

도구 모음 편집기를 닫으면 도구 모음의 현재 상태가 편집 중인 UI와 함께 저장됩니다. 레이아웃 편집기에는 도구 모음이 표시되지 않지만 프로그램을 실행하면 확인할 수 있습니다.

툴 아이콘 편집하기

GUIDE에는 도구 모음의 아이콘과 같은 아이콘을 생성하고 수정하는 대화 상자인 자체적인 아이콘 편집기가 있습니다. 이 편집기는 도구 모음 편집기에서만 액세스할 수 있습니다. 다음 그림은 표준 Save 아이콘을 불러온 아이콘 편집기를 보여줍니다.

아이콘 편집기 사용하기

아이콘 편집기 대화 상자에는 다음 구성요소가 있습니다.

  • 아이콘 파일 가져오기(Icon file name) — 편집하기 위해 불러올 아이콘 이미지 파일입니다.

  • 가져오기(Import) 버튼 — 기존 아이콘 파일을 편집하기 위해 선택할 수 있는 파일 대화 상자를 엽니다.

  • 그리기 툴 — 아이콘 편집에 사용할 수 있는 네 가지 툴로 구성된 그룹으로 왼쪽에 표시됩니다.

    • 연필 툴 — 클릭하거나 끌어서 놓는 방법으로 아이콘 픽셀에 색을 칠합니다.

    • 지우개 툴 — 클릭하거나 끌어서 놓는 방법으로 픽셀을 투명하게 지웁니다.

    • 페인트 통 툴 — 동일한 색의 픽셀 영역을 현재 색으로 채웁니다.

    • 색 선택 툴 — 픽셀 또는 색 팔레트 견본을 클릭하여 현재 색을 정의합니다.

  • 아이콘 편집 창(Icon Edit) — 아이콘을 색칠할 nxm 그리드입니다.

  • 미리보기(Preview) 창 — 아이콘의 현재 상태에 대한 미리보기가 있는 버튼입니다.

  • 색 팔레트(Color Palette) — 연필 및 페인트 툴이 사용할 수 있는 색 견본입니다.

  • 추가 색(More Colors) 버튼 — 색을 선택하고 정의하기 위한 색 대화 상자를 엽니다.

  • 확인(OK) 버튼 — 대화 상자를 닫고 현재 상태의 아이콘을 반환합니다.

  • 취소(Cancel) 버튼 — 현재 상태의 아이콘을 반환하지 않고 대화 상자를 닫습니다.

아이콘 편집기를 사용하려면 다음을 수행하십시오.

  1. 선택한 툴의 아이콘에 대해 아이콘 편집기를 엽니다.

  2. 연필 툴을 사용하여 그리드의 정사각형에 색을 칠합니다.

    • 팔레트에서 색 셀을 클릭합니다.

    • 색 팔레트(Color Palette) 미리보기 견본에 해당 색이 표시됩니다.

    • 그리드에서 특정 정사각형을 클릭하여, 선택한 색을 이 정사각형에 색칠합니다.

    • 왼쪽 마우스 버튼을 누른 상태로 그리드 위로 마우스를 끌어서 놓아, 선택한 색을 해당 정사각형에 색칠합니다.

    • 다른 색으로 덮어써서 색을 변경합니다.

  3. 지우개 툴을 사용하여 일부 정사각형에서 색을 지웁니다.

    • 팔레트에서 지우개 버튼을 클릭합니다.

    • 특정 정사각형을 클릭하여 지웁니다.

    • 마우스를 클릭한 상태로 끌어서 놓아 선택된 정사각형을 지웁니다.

    • 지우개를 비활성화하려면 다른 그리기 툴을 클릭하십시오.

  4. 확인(OK)을 클릭하여 대화 상자를 닫고 생성한 아이콘을 반환하거나 취소(Cancel)를 클릭하여 선택한 툴의 아이콘을 수정하지 않고 대화 상자를 닫습니다.

아래에 도구 모음 편집기와 아이콘 편집기가 함께 나와 있습니다.

관련 항목